It's all about the answers!

Ask a question

lscm (scm) command line very slow (solved)


Brett Waldo (951020) | asked Sep 30 '14, 10:21 a.m.
edited Jan 16 '15, 10:18 a.m.
Ticket created twice, active one is @ lscm (scm) command line very slow


 The sounds like a duplicate from my searches, but it is so slow I feel like something has to be configured wrong. Every command takes at least 10 seconds, many take 30-40 seconds. 

I'm using RTC5.0.1, which has supposed improved command line.  As is on my system, it would be faster to print out the oracle database each time and just look at the table data.  We are new to RTC so our server has very little data.

System Spec:
Client: RHEL6 32 bit, 16 cores, 14GB Ram, java -version = java version "1.7.0_25"
Server RHEL6, 64 bit, 24 cores, 50 GB Ram
Database Server RHEL6, 64 bit, 24 cores, 50GB Ram, Oracle backend
1GB network, same switch

Here is short session with the output of how long each command took, note working with a very small component:
time lscm login -r https://[host]:9443/ccm -n local --cache
real    0m38.958s

time lscm list workspaces -r local
[returns all 5 records]
real    0m15.882s

time lscm list streams -r local
[returns all 4 records]
real    0m15.993s

time lscm list components -r local
[returns first 10 records]
real    0m16.073s

time lscm load -r local -d checkout 1001 1006
real    4m10.082s

du -hs checkout/
179M    checkout/

time lscm status
real    0m53.962s

time lscm logout -r local
real    0m15.715s

Inspection of the log file shows the following error message printed 3 times / second. Even while no commands are executing:
<record>
  <date>2014-09-30T10:11:39</date>
  <millis>1412086299362</millis>
  <sequence>1686619</sequence>
  <logger>com.ibm.team.filesystem.client</logger>
  <level>SEVERE</level>
  <class>com.ibm.team.filesystem.client.internal.LoggingHelper</class>
  <method>log</method>
  <thread>72</thread>
  <message>com.ibm.team.filesystem.client.FileSystemException: Error loading map info</message>
</record>




One answer



permanent link
Arne Bister (2.6k12432) | answered Oct 01 '14, 11:24 a.m.
JAZZ DEVELOPER
Brett,

please cp. https://jazz.net/wiki/bin/view/Deployment/RTCClientPerformance#Command_line_interfaces_CLIs to references how to enable Metronom and additional logging for command line to pinpoint exactly what is causing the performance issue you are observing.

- Arne

Comments
Brett Waldo commented Oct 01 '14, 12:57 p.m.

This ticket was created twice by the system.  I have copied your question on the other post, and tried to answer it there.

lscm (scm) command line very slow

Your answer


Register or to post your answer.