It's all about the answers!

Ask a question

Error uploading file: CRJAZ6053E The 'Save Attachment' operation cannot be completed.


Ryan Martin (2111) | asked Dec 10 '13, 2:21 p.m.
We're getting the above message, including "Permission is required to complete the operation." when trying to save an attachment onto a work item in CCM 4.0.5. I've checked the licenses, no apparent problem there. I've reviewed the users' roles (Developer & Analyst) and verified that they have permission to create, modify, remove, and delete attachments on work items. They were forbidden to create attachments without a work item in context. When I grant permission to those roles to Save/Modify/Delete Attachment (without work item context) the attachment to work items begins working with no permission error.

Why might the permissions for no-context attachments be being applied to attachment operations in work item context?

One answer



permanent link
Kot T. (1.5k11219) | answered Dec 11 '13, 1:55 p.m.
JAZZ DEVELOPER

Hi Ryan,

Could you provide more details on how you configure your project area to forbid to create attachments without a work item context?


Comments
Ryan Martin commented Dec 11 '13, 2:08 p.m.

 It's the default configuration in the Formal Project Management Process template when creating a Lifecycle Project. The predefined roles "Developer" and "Analyst" have permission granted to Work Items->Save Work Item->Modify the work item->Modify the work item's links->Modify the work item's attachments->*. They do not have permission for Work Items->Save Attachment, or its children ->Delete Attachment or ->Modify Attachment. 


The tooltip text on permission Work Items->Save Attachment reads: "The Save Attachment operation is executed whenever an attachment is saved in the repository without a work item in context."

I took this to mean that this permission only applies when an attachment is saved without a linked work item. However, it seems to apply to all saving of attachments through the web interface, even when the attachment is requested for a specific work item through the "Links" tab on its web page. I have not tried to save attachments through other interfaces, e.g. the RTC Eclipse plugin. 


Kot T. commented Dec 11 '13, 3:30 p.m.
JAZZ DEVELOPER

Ryan, thanks for the clarification. I wonder if this is something specific to how the project is created. In 4.0.5, I have a project created from the Formal Project Management Process template which the default settings as you described: Save attachment is OFF for all roles, but Modify the work item's links -> Modify the work item's attachements is checked for the process role that I am assigned with on this project. I am able to add and save attachment in a work item.

I haven't tried to create a formal project from a LPA project.

Your answer


Register or to post your answer.