It's all about the answers!

Ask a question

RTC Web UI: Last 'description' or HTML shows as ready to enter data whilst first one requires user to click 'edit'


Richard Tweed (811118) | asked Nov 13 '13, 7:03 a.m.

I have two fields of type 'description' within the same tab.  The last one always loads as being ready for the user to enter data (edit mode), however the first one always requires the user to click 'edit' before they can enter the text.

The desired behaviour is for the first 'description' field to be ready to accept the users text.  Is there a way to do this?             


 

Comments
Millard Ellingsworth commented Nov 22 '13, 6:17 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

What version are you using? I've seen this issue before and I think it was related to the Description field implementation only allowing one field to be "open" at a time and the behavior seemed to be that the last one was the one opened. But the editor implementation was changed recently -- so we need to know your version to make sure we're answering correctly.


Richard Tweed commented Nov 25 '13, 2:06 a.m.

Ahh yes, I really should have entered that too.  We're using 4.0.3.

Accepted answer


permanent link
Millard Ellingsworth (2.5k12431) | answered Nov 25 '13, 2:32 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
Testing on 4.0.3 I see that it is still the case that only one Description (or perhaps even Large HTML attribute) can be open for editing at one time. Clicking Edit on one that isn't open automatically puts the previously open one into Preview mode. In my testing, the first one happened to be the one that was immediately available for editing, but I don't think there is any guaranteed behavior related to that. 

This behavior seems to differ by browser: In Chrome, the first one was ready for edit, in Firefox and IE, the last one. You are certainly welcome to file a defect indicating that there should be a guaranteed behavior and that it should be consistent across browsers.
Richard Tweed selected this answer as the correct answer

Comments
Richard Tweed commented Nov 25 '13, 3:56 p.m.

From the response, it sounds like this behaviour differs in 4.0.4 and above?


Millard Ellingsworth commented Nov 25 '13, 5:06 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Checking this on 4.0.5, the preview/edit toggle is gone -- both fields are "open" and accepting edits (so you may not want to bother with a request as you'll likely be requested to upgrade).

Your answer


Register or to post your answer.