It's all about the answers!

Ask a question

Unable to sort by clicking column heading for custom attribute using web client


Susan Hanson (1.6k2190193) | asked Oct 29 '13, 3:06 a.m.
RTC 4.0.0.1

I have a shared query with the result columns being both built-in and custom attributes.

When I run the shared query in an Eclipse 4.0.0.1 client, I am able to click on the column headings for the custom attributes and it sorts on that column.

When I run the same shared query in the Web Client (using FireFox), the column headings are not click-able and I am unable to sort.

Is this a known problem? 
Susan

2 answers



permanent link
Ralph Schoon (61.2k33643) | answered Oct 29 '13, 4:29 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Susan, I tried that with a 4.0.0.1 server and sorting worked for me in the web UI.
Please note, sorting did not work while I was editing the query. Also, please be aware, the sort indicator appeared after I clicked on the column. There might be attributes that are not sortable and there might be issues with custom attributes, I think I remember that there were some issues.

Comments
Susan Hanson commented Oct 29 '13, 6:54 a.m.

I'm able to recreate it on IE8 with the same shared query.  I am actually running the query straight from a URL for runSavedQuery&id=_<blah>.

If I look at the headings, the "built-in" ones are in bold, and if you hover over them, there is help text that indicates you can sort.  If I look at the 3 custom attributes (they are Enumerations by the way), these 3 column headings are NOT in bold, and you get nothing if you attempt to hover over the heading text.  Note bold headings and hover txt



See how Functional Area, TargetRelease, and RETAIN Release headings are NOT bold, and those are the ones I can't sort with.

Susan


Ralph Schoon commented Oct 29 '13, 7:06 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I am unsure of what type these attributes are, but again, they are custom attributes and might therefore not be sortable or they might be of a type that has no order defined and are therefore not sortable.


Susan Hanson commented Oct 30 '13, 10:18 a.m.

They are enumerations which contain String values.

I can sort them in the Eclipse client by clicking on the column heading.  So RTC is able to figure out how to sort these in the Eclipse client without any issues.

I am happy to open a PMR to have someone look at this if it is not a known bug, as it is easily reproduceable.

Susan


permanent link
Philippe Poisvert (3122) | answered Jan 29 '14, 12:01 p.m.
Hello,
I got the same problem in 4.0.3, all columns are sortable (Priority -> enumeration, Category ...) BUT columns corresponding to customize attributes are not sortable.
Did you get return from your PRM ?
Do you know if the pb. is solved in later releases 4.0.4, 4.0.5 ?
Thanks

Comments
Susan Hanson commented Jan 29 '14, 4:09 p.m.

I had opened an enhancement which was dup'd to enhancement 275573, which is still in NEW state.

Your answer


Register or to post your answer.