It's all about the answers!

Ask a question

Parameter issue with Work Items by Owner Report


Dolores Vogel (103922) | asked Jun 07 '18, 4:54 p.m.

 We're using RTC 6.0.5 iFix004. The out-of-the-box report Work Items by Owner has a parameter for Type. That parameter does not show all types in our project area. Our guess was that it only shows types that exist in the repository, but we have several Tasks, and Tasks did not show as an option. Can anyone explain this behavior?

One answer



permanent link
Kenji Sarai (96029) | answered Jun 12 '18, 5:48 a.m.

Hi Dolores,

I remember it happened if the missing type has never been used in any WI. Try below
1. Refresh the meta-model manually
http://www-01.ibm.com/support/docview.wss?uid=swg21986146

2. Use missing type (eg Tasks) at least in one work item, and run (delta) DCC job, then refresh mete-model to see if it makes any difference.


Comments
Dolores Vogel commented Jun 12 '18, 12:18 p.m.

There are several work items with Type=Task, and Task did not show as an option. The tasks have been in there for over a year. I could see Task when I ran the report. Another user could not. The only difference between us is that she was not an owner on any tasks before the day we were running the report, but since tasks existed, I would think the other user should have seen the option when she ran the report. 


Kenji Sarai commented Jun 13 '18, 1:21 a.m.

This is quite weird behavior. If she does not have access permissions to this project area, then she cannot select the project in project selection.

What if you make changes in these Task workitems in RTC and let DCC job run to load these workitems again? Does it make any difference? If it gets fixed, then something went wrong in DCC job when these workitems has been last modified.

Your answer


Register or to post your answer.