It's all about the answers!

Ask a question

Is CSV Import broken when updating 'Planned For' attributes?

Andrew Codrington (17733135) | asked Oct 16 '13, 4:54 p.m.
Jazz 4.0.2

Steps to reproduce:
- Create query in web UI to pull a number of existing WI from a specific iteration, including Planned For attribute in display columns
- In Eclipse, Export WI to csv from above query. No errors reported.
- In spreadsheet app (LibreOffice Calc 4), open csv and edit Planned For (this may not even be necessary. In one test I simply exported and imported with no external editing)
- In Eclipse, Import WI from csv to correct Project Area. No errors reported.
- In web or Eclipse refresh query results.

Expected behaviour:
- Query shows same number of WI in result set as at start

Actual result:
- Query is empty

Note that I can do another query for 'WI Modified by me today' and see all the updated WI.
The Planned For attribute appears to be correct.
The WI just don't show up when the query is on the specific Planned For iteration.
I haven't done more testing on behaviour with other attributes.

I did a few quick searches in the CCM PA with no obvious known defects.
Is this a known issue?

Eric Jodet commented Oct 18 '13, 2:36 a.m.

 Hello Andrew,

  • If exported from RTC, the Planned For attribute should use the Internal Value presentation to be fully qualified

Andrew Codrington commented Oct 31 '13, 4:40 p.m. | edited Oct 31 '13, 4:41 p.m.

I think the Internal Value is the smoking gun.

I was not using it. On import a new iteration was being created with the original name but under a different timeline.

This meant that visually it looked like it was in the right place, since most UI just shows the iteration name, not the timeline it's on.

All my queries were against the correct timeline, so none of the work items were returned.

I finally noticed one day while editing the project timelines. I expanded a timeline we haven't used much lately and saw a duplicate of my iteration there. Along with your hint above it all suddenly made sense!

If you convert your comment above to an answer I can mark it as 'The Correct One'.

One answer

permanent link
Eric Jodet (6.3k5111120) | answered Oct 17 '13, 5:25 a.m.
 Hello Andrew,
I tried and reproduce your issue in my debug RTC 4.0.5M2 env,
each time - behavior is as expected, in the WebUI:
- if not changing the Planned for attribute in the CSV file, query shows the same result
- if changing Planned For attribute for a couple of items in the CSV file, refreshing the query will show expected results.

Please elaborate a more detailed use case:
- exact query params
- confirm if you change or not attributes in the CSV file
- CSV import options (update / create)


Your answer

Register or to post your answer.