It's all about the answers!

Ask a question

[closed] CRJAZ6053E 'Save Category' operation cannot be completed


Simon Eickel (1.1k75357) | asked Sep 13 '13, 5:23 a.m.
closed Oct 17 '13, 6:04 a.m.
Hi everybody,

we're facing one curious error which seems a bit mystical to me - maybe someone can enlighten me ;)

We adopted one new role to our process which is called "Team Admin P" and grants our Project Admins the special rights for changes within the Project Area level. E.g. creating and changing timelines and categories.
Just a small set of users have this role.

Everything worked fine with this structure that only the project administrators are able to modify and create project specific items - until now.

One of our project administrator is facing trouble now.
He has the role "Team Admin P" within this project area and was able to change the associated teams for some categories.
Since Tuesday (3 days ago) he's facing the error that when associating a new team to a category he get's this Error:

Nothing else appears (no Details button) than this message.
When pressing the "Save" button again and again it's ok after some tries and he changes the association.
I did check this as my account on the category overview and for me it was changed, too.

Than ... some hours later the team association got released again and the old team is associated with the category (hope the explanation is ok for you).

This behaviour was checked with FireFox 23 and at the moment this user is the only facing this problem.
IE could not be checked atm as the IE is not on his system.

We checked firebug and got this messages:
GET https://jazzqual.rsint.net/ccm/service/com.ibm.t...AreaItemId=_kyryUAbsEeKj1pxR9z-V2w&maxMembers=20    200 OK        234ms    dojo.j...RL=/ccm (Zeile 10596)
GET https://jazzqual.rsint.net/ccm/service/com.ibm.t...ce/projectHierarchy?uuid=_kyryUAbsEeKj1pxR9z-V2w    200 OK        78ms    dojo.j...RL=/ccm (Zeile 10596)
GET https://jazzqual.rsint.net/ccm/process/project-areas/_kyryUAbsEeKj1pxR9z-V2w/links    200 OK        31ms    dojo.j...RL=/ccm (Zeile 10596)
GET https://jazzqual.rsint.net/ccm/service/com.ibm.t...iningProjectAreaUrl?uuid=_kyryUAbsEeKj1pxR9z-V2w    200 OK        2,67s    dojo.j...RL=/ccm (Zeile 10596)

GET https://jazzqual.rsint.net/ccm/proxy?uri=https%3...ns%252Fui%2523HomeMenu%26scope%3DincludeExternal    304 Not Modified        312ms    dojo.j...RL=/ccm (Zeile 10596)
POST https://jazzqual.rsint.net/ccm/service/com.ibm.t...nal.rest.IWorkItemRestService/workItemCategories    400 Bad Request        406ms    dojo.j...RL=/ccm (Zeile 10596)


POST https://jazzqual.rsint.net/ccm/view-history    200 OK        121ms    dojo.j...RL=/ccm (Zeile 10596)
GET https://jazzqual.rsint.net/ccm/home-menu-project...cm/process/project-areas/_kyryUAbsEeKj1pxR9z-V2w    200 OK        16ms    dojo.j...RL=/ccm (Zeile 10596)

Error: Unable to load /ccm/web/dojo/../../service/com.ibm.team.workitem.common.internal.rest.IWorkItemRestService/workItemCategories status:400
_resHandle()dojo.j...=%2Fccm (Zeile 10490)
_watchInFlight/func()dojo.j...=%2Fccm (Zeile 10373)
_watchInFlight()dojo.j...=%2Fccm (Zeile 10392)
    ...ar err = new Error("Unable to load " + dfd.ioArgs.url + " status:" + xhr.status)


Anyone any ideas what went wrong?
Why does the association is present after some tries and gets released again, some time later?

I didn't find any entries within the ccm / jts server log files but in the websphere log there is something written which could fit the time:
[9/13/13 10:53:12:233 CEST] 0000001f srt           W com.ibm.ws.webcontainer.srt.SRTServletResponse setStatus WARNING: Cannot set status. Response already committed.
Hope you can help me as this is a really annoying error.

Greetings,
Simon

Comments
Simon Eickel commented Sep 13 '13, 5:40 a.m.

Some more specific information:
Server is running on Win 2008 R2 with RTC 4.0.3.
Database is SQL Server 2008 R2 (still waiting for support of SQL Server 2012)

OS of the client is Windows 7 x64

The question has been closed for the following reason: "The question is answered, right answer could not be accepted as it is my own" by eickel Oct 17 '13, 6:04 a.m.

3 answers



permanent link
Eric Jodet (6.3k5111120) | answered Sep 13 '13, 5:33 a.m.
JAZZ DEVELOPER
 Hello Simon,
which was resolved as a dup of
which was resolved / fixed in RTC 4.0.3

Which version of RTC are you using?
Could the above defects match the behavior you observe?

Thanks,
Eric

Comments
Simon Eickel commented Sep 13 '13, 5:39 a.m.

Hi Eric, sorry I forgot - gave more specific information about the system in the top post.

To answer your question - we are using 4.0.3 :(


Eric Jodet commented Sep 13 '13, 6:33 a.m.
JAZZ DEVELOPER

 umm -(


A 400 response often means something bad happened at server level (ex : a NPE)
May you please check the JTS/CCM logs at the exact time you reproduce the issue?

Depending on your findings, feel free to open a new defect so we can investigate further.

Thanks
Eric.


Simon Eickel commented Sep 13 '13, 6:52 a.m.

Hi Eric,
In the ccm / jts logs I did not find anything. The only entry was in the WAS logs - I will try to get the user again to reproduce the problem and again searching the logfiles ...


Simon Eickel commented Sep 13 '13, 8:08 a.m.

Hi Eric,
we reproduces this error on IE and I searched all log files - no entries left. Neither in ccm / jts nor in the WAS logs ...


Eric Jodet commented Sep 13 '13, 8:15 a.m.
JAZZ DEVELOPER

 Hello,

you may open a defect - please ensure to provide all the details / steps / material (template, pa source).
If some data is confidential, feel free to open a PMR

Thanks,
Eric


Simon Eickel commented Sep 14 '13, 4:30 a.m.

Hi Eric,
thanks I will do this.
But at the moment I'm upgrading to 404 and check afterwards if this solved the problem. Otherwise I will open a Defect / PMR.


Simon Eickel commented Sep 16 '13, 3:30 a.m.

unfortunately with 4.0.4 this error still exists.
The user has logged into my IE with his credentials now so I have an account to reproduce it ... and yes: This error comes up on my PC, too.

Opening a PMR now.

showing 5 of 7 show 2 more comments

permanent link
Simon Eickel (1.1k75357) | answered Sep 16 '13, 8:34 a.m.
Just to share my findings with you:
I got this problem solved but I don't know really why :o\

In our environment we are using process sharing.
We got one standardized Process which is called "R&S Master Process". This process template is used in each other project area.
In this process template all standardized things are set, e.g. two new roles which are called "Team Admin P" and "Team Admin T".
The role "Team Admin P" grants permission for the project area level to administrators, e.g. the permission to create and modify categories:


Seeing this a member of the project area having the role "Team Admin P" should be able to modify and create categories.
On some users this worked on some not ...

Looking at the project area itself (seeing the inheritance sign) the permission was set, too:

Don't know why this made such a trouble ...
How did I solve this?

Well ... one can say it was some kind of "desperate deed". What I did was just overwriting the inheritance - granted this permission directly to the project area. And see - it worked.
But ...as our policy is that permissions and roles shall be inherited from the master process I revoked such overwritings so that the inheritance of this permission was back from the master process and look - it's still working.

Don't know what happend but for me it looks like there was some stupid inconcistency between the real permission and the permission he told me.

This seems to be solved and I did not need to open a PMR by myself :)

Thanks for your help,
Simon

permanent link
Eric Jodet (6.3k5111120) | answered Sep 16 '13, 8:51 a.m.
JAZZ DEVELOPER
 Hello Simon,
OK, permissions and roles are inherited from master PA
https://jazz.net/help-dev/clm/topic/com.ibm.jazz.platform.doc/topics/c_sharing_project_area_process.html

However, members are not inherited.
Say you're member of Team Admin P in master PA,
but if you're not member of such role in child PA, then you might have the permission issue.

Eric.

Comments
Simon Eickel commented Sep 16 '13, 9:33 a.m.

Hi eric,
this is clear.
but in our case in the master process template no members are defined.
The member definition is only done in the child project areas.

That's why I don't understand that it was not working.


Eric Jodet commented Sep 16 '13, 9:36 a.m.
JAZZ DEVELOPER

 ok Simon,

let's see the outcome of the PMR :-(
Do you have PMR # for reference?

Thanks


Donna Thomas commented Jul 27 '15, 3:04 p.m.

Sorry about resurrecting a really old thing... but this is exactly what is happening with us too. We are running 4.0.5, with similar master-child process... users are all in the children, but all have access to the master. Also this happens for a lot more than just THIS permission - we've just experienced it with this permission, but have also see it with some of the source control permissions, like changing stream visibility. And we have a few more issues with permissions that I'm now going to investigate to see if they apply like this.


Geoffrey Clemm commented Jul 28 '15, 1:04 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

In a case like this, I suggest opening a new question, and include in your question a reference to the previous question.   I'm guessing that you will not get an answer, and that your best approach is to work with IBM Support on this.   (You could try the hack that seemed to fix it for Simon, but it would be better if we could find out what is going wrong, so we can fix it in the product).