It's all about the answers!

Ask a question

RTC Eclipse client connections to local host and enterprise JTS

Michael Taylor (8865764) | asked Aug 23 '13, 10:17 a.m.

I installed the Windows 7 JTS/RTC 4.0.1 download on my local workstation.  So locally, I'm running the JTS in Windows 7 on top of the Apache derby DB, Tomcat, etc.  I also installed the RTC eclipse client on that same workstation.

What I found early on is that I could only make a JTS connection from the RTC eclipse client if I turned my wifi off and/or disconnected my network cable to the network.  If I had any valid network connection to my workstation, I could not connect to the local JTS even though it was started up.  I could toggle the JTS connection on and off by simply enabling or disabling a valid network connection on my workstation.  I believe my RTC eclipse client "Network Connections" were set to the "Active Provider" of "Native".

Later, when adding a new repository connection to our enterprise JTS, I found that I could only make that connection work if I switched the RTC eclipse client "Network Connections" setting to the "Active Provider" of "Direct".  With the "Direct" setting and after restarting the RTC eclipse client, I found that the behavior described above for local JTS connections didn't change.

My question is how can this be configured so that my RTC eclipse client can access the local repository and the enterprise repository at the same time while maintaining a constant, valid network connection to my workstation?

Accepted answer

permanent link
Abraham Sweiss (2.4k1331) | answered Aug 23 '13, 11:27 a.m.
I have several instances of CLM running on my windows 7 laptop for testing, and have no issues connecting to them with or without a network connection.  The one thing to check for is to be sure the hosts file is configured where the servername being used is mapped to the loopback IP of  This should prevent an external DNS lookup when attempting to connect to the rtc instance running on your workstation.
Michael Taylor selected this answer as the correct answer

Michael Taylor commented Aug 23 '13, 1:22 p.m.

Thanks.  I found the standard hosts file on my Win 7 machine to be all comments.  I added the following line and that did the trick!  Thanks for the tip on the hosts file.


One other answer

permanent link
sam detweiler (12.5k6194201) | answered Aug 23 '13, 10:47 a.m.
sounds like the local firewall is blocking local access..  Eclipse doesn't care.

I always connected to my enterprise RTC and localhost with the same eclipse client at the same time.
(enterprise system connected via vpn).

Michael Taylor commented Aug 23 '13, 10:51 a.m.

I'm also connecting to the enterprise JTS via VPN.  I think an enterprise firewall may have had something to do with the fact that I had to use the "Direct" RTC eclipse client Network Connections setting.

If I do have a local firewall that is blocking local access, does it make sense that the local firewall doesn't block access when there is no valid network connection but it does when there is a valid network connection?

sam detweiler commented Aug 23 '13, 11:00 a.m.

i don't know. I have a local home lan. I also have RTC running on my personal system (where I do exploratory development of all kinds)..
when I am vpn connected to work, I cannot access my home lan AT ALL, except for print, to a specific IP address range.

but RTC running on the vpn connected machine is accessible as well as the vpn connected servers.

localhost should ALWAYS exist.. even on a network of 1 machine.
localhost should be always

Michael Taylor commented Aug 23 '13, 1:23 p.m.

Thanks for nudging me in the direction of the local hosts file as well!

Your answer

Register or to post your answer.