It's all about the answers!

Ask a question

RTC 4.0.3 is installed by the express setup, but no setup page is not displayed

Joseph Kwon (1111) | asked Jul 24 '13, 5:41 p.m.

JTS and CCM are installed on Windows 2008 R2 server, 64-bit, 6 GB RAM. Disabled security certificate setting and went to  Got an error "IE cannot display the webpage".  Confirmed that Tomcat 7.0.32 is successfully installed with

This server hosts ClearCase and ClearQuest Client as well.  ClearCase/ClearQuest 8.0.x was installed on d: drive before RTC installation and RTC was installed on e: drive. 

Clement Liu commented Jul 24 '13, 6:22 p.m.

 Hi Joe,

Why did you disable security cert? I just tested with my tomcat installation and the hit to was redirected to

Can you try again on a Firefox/Chrome browser (without disabling security cert)? 


4 answers

permanent link
Abraham Sweiss (2.4k1331) | answered Jul 24 '13, 7:20 p.m.
Hi Joseph,

I would do the two following checks
1. Before starting tomcat, do a netstat -an to see if another process is using that host:port combination
2. Do a sanity check and confirm that in the Tomcat configuration http requests are not being redirected to https
3. Scan the catalina logs for errors

permanent link
Alastair Beadle (19411218) | answered Jul 25 '13, 4:32 a.m.
Hi Joseph,
The default installation would use secure HTTP - so your setup webpage would be https://hostname... rather than http://hostname... That might cause the symptom you are seeing.

permanent link
Abraham Sweiss (2.4k1331) | answered Jul 25 '13, 8:17 a.m.
Hi Joseph

TO confirm if http or https protocol is being used for the public uri, review the jts file. 

BTW: I beleive during the express set up there is the option to specify the public uri.  By default  it should be filled in using the information from the url used to access the jts/setup wizard.

permanent link
Karl Weinert (2.0k52736) | answered Jul 25 '13, 8:54 a.m.
 6 gigs of ram is not enough memory to run RTC as configured by default.
You should open the server.startup script and remove the -Xgc:preferredHeapBase=0x100000000 setting near the bottom.

set JAVA_OPTS=%JAVA_OPTS% -Xgcpolicy:gencon
set JAVA_OPTS=%JAVA_OPTS% -Xcompressedrefs -Xgc:preferredHeapBase=0x100000000

Depending on what else is running on that system you may want to cut down on the XMX and XMS settings as well.
That would only be recommended in a non production environment. If it is in production you should get more memory for your system.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.