It's all about the answers!

Ask a question

Does RTC add bytes to files when they are checked in?? If so can this behavior be controlled?


Timothy Hague (1623) | asked Aug 20 '13, 2:05 p.m.
retagged Aug 20 '13, 2:21 p.m. by Te-Hsin Shih (2854)
Hello,
I'm checking in XML files into RTC and I notice that the file size increases slightly after the checkin. This is causing me some unexpected results when comparing files sizes to the original files that are given to me via an end user. Is this expected behavior? Can I turn this behavior off? What exactly is being added to these files?
Thanks much,
Tim Hague

Comments
Remy Suen commented Aug 20 '13, 2:12 p.m.

Does this only happen with XML files? Is the numerical increase in file size consistent across all your files?

Accepted answer


permanent link
Te-Hsin Shih (2854) | answered Aug 20 '13, 3:36 p.m.
The eclipse preference setting only affects new file. It would not apply to existing files. If you want to change the line ending delimiter for existing files, you need to change the delimiter setting for each individual files (by select each file -> team -> change file properties...). After you changed the file properties, you need to check in your changes.
Timothy Hague selected this answer as the correct answer

Comments
Timothy Hague commented Aug 20 '13, 3:45 p.m.

Many thanks, this worked...

2 other answers



permanent link
Timothy Hague (1623) | answered Aug 20 '13, 2:18 p.m.
It looks like only XML and yes it appears to be a consistent amount that's added...

Comments
Te-Hsin Shih commented Aug 20 '13, 2:26 p.m.

Do you notice what has been changed in the file? Is it the line ending characters? If that is the case, then there is a line ending character setting for the file. If you do not want RTC to change the line ending delimiter, you can either set the file ending character to None or the format matches to the file that was checked in.


permanent link
Timothy Hague (1623) | answered Aug 20 '13, 3:27 p.m.
Thanks for the advice, I'm trying to update this via preferences but I'm still seeing the byte changes. Below is what I tried:

Windows>Preferences>Team>Jazz Source Control> File Properties>Text>XML>*.xml set Line Delimiter to "None (Binary)" and select Apply and Ok...restarted the workbench. When I import the original file and checkin again I'm still seeing the same behavior...any hints?
Thanks very much for your help so far... File Properties Editor

Your answer


Register or to post your answer.