It's all about the answers!

Ask a question

Problem Installing RTC 4.0.3 Into Eclipse Juno


Chris Barlock (18813937) | asked Jul 30 '13, 3:28 p.m.
I unpacked the Eclipse 4.2 SR2 Java EE bundle and started Eclipse.  I then downloaded RTC-Client-Eclipse4.2-repo-4.0.3.zip and unpacked it.  I added a new Software Site, file:/C:/D/tempInstall/RTC-Client-Eclipse4.2-repo-4.0.3/im/repo/rtc-client-full-p2-offering/offering-repo/.  I can click the Reload button on the Software Sites dialog and get a message that the information for this repo has been loaded from the server -- so Eclipse seems to think this is a valid Software Site.  However, when I try to use this site, I'm told that there are no items available for installation.

Oddly, I used this same mechanism to install RTC 4.0.1 back when we upgraded our server to 4.0.1 and it worked just fine.  (Today's installation was into a fresh Eclipse directory tree; it was not an attempt to upgrade 4.0.1 to 4.0.3.)  Any thoughts on what might be wrong?

Chris 

Comments
Clement Liu commented Jul 30 '13, 3:57 p.m. | edited Jul 30 '13, 4:07 p.m.

Hi Chris,


This might have been a Eclipse bug. Can you try this? Uncheck "Group items by category"...


Chris Barlock commented Jul 30 '13, 4:06 p.m.

Thanks, Clement.  I did try that -- it didn't make any difference.
Chris

Accepted answer


permanent link
Clement Liu (1.5k54149) | answered Jul 30 '13, 4:18 p.m.
edited Jul 30 '13, 5:45 p.m.
Not sure why it was working for your 4.0.1 but you were supposed to use IBM Installation Manager with the RTC-Client-Eclipse4.2-repo-4.0.3.zip. Can you try using the p2 repo instead? 

1. Download this p2 repo

2. Follow this instruction to have it installed in your 4.2 SR2 Eclipse. Skip to Step 5

Hope it helps. Thanks.
Chris Barlock selected this answer as the correct answer

Comments
Chris Barlock commented Jul 30 '13, 4:25 p.m.

Ohhhhh!  I guess the "im" in the path should have been a clue.  Thanks, both Tim and Clement!  However, there must be something wrong with jazz.net right now.  When I try to download this p2Repo, I accept the license agreement, get to a page where my download should begin shortly.  It doesn't, so I click the provided link and get:

Error 400

https://199.246.40.117:9443/mirror/downloads/rational-team-concert/4.0.3/4.0.3/RTC-Client-p2Repo-4.0.3.zip?tjazz=LX6m3Ph4ugs560n89LeXspor34rg97".


Bo Chulindra commented Jul 30 '13, 5:37 p.m.
JAZZ DEVELOPER

I just tried https://jazz.net/downloads/rational-team-concert/releases/4.0.3/RTC-Client-p2Repo-4.0.3.zip and it worked fine. Maybe the problem with jazz.net has been fixed.


Chris Barlock commented Jul 30 '13, 8:17 p.m.

Yes, just tried it myself.  It is working now and the p2Repo is what I needed.  Thanks to all!

Chris

One other answer



permanent link
Tim Mok (6.6k38) | answered Jul 30 '13, 4:09 p.m.
JAZZ DEVELOPER
The path suggests you downloaded the IM install, which is a different type of repository. If you're using the Eclipse p2 install, you'll need the p2 repo. Otherwise, you can get Install Manager and use the IM repo that you have.

Your answer


Register or to post your answer.