It's all about the answers!

Ask a question

How can I resolve a "HTTP 502: Proxy Error" when trying to import a Subversion 1.7 dump file into RTC 4.0.2?


Ryan McBryde (341817) | asked Jul 24 '13, 3:21 p.m.

I am trying to import a dump file from subversion 1.7 into RTC 4.0.2 and it runs for a while and then eventually fails with the message:

An error occurred importing 'Revision 1072: [metilda.mariadoss] (1/25/12 8:15 AM) To fix My Account-Password management (APSP00000739)': CRJAZ0098E The com.ibm.team.scm.common.internal.IScmImportService{/ccm/service/com.ibm.team.scm.common.internal.IScmImportService} service failed.  The server returned the HTTP error 502 with this error text: Proxy Error.

I have run the import twice, into a different component each time, and it has run for a different amount of time each time and failed at a different spot in the import.  The first time it ran for 20 minutes and failed.  The second time it failed after 85 minutes.

I have tried to research the error and have found very little on the CRJAZ0098E error, (very little) and on the HTTP 502 error.  What I have gleaned from that research is that it appears that one server loses it connectivity to another server which is performing some task.

I don't know how to proceed with this and I have a number of SVn repos to import.  Any assistance/insight would be appreciated.

Thank you



Comments
Surya Tripathi commented Jul 24 '13, 4:08 p.m.

What kind of RTC database are you using? Is it the default DB that comes with RTC? How big your SVN project?


Ryan McBryde commented Jul 24 '13, 4:35 p.m.

Thanks for the response,

The RTC database is SQL Server and now we created a new one.

We are also using Websphere 8.

The SVN dump file is 248,529 KB.

 Ryan


Krzysztof Kaźmierczyk commented Jul 25 '13, 3:20 a.m.

Hiu Ryan,
Do you have any proxy server between your RTC client and server (e.g. IHS)? To see the entire stack trace you need to look into ccm.log file located in <WAS-install>/profiles/<your-profile>/logs.
Please past here the content of this file and we will try to help you.


Ryan McBryde commented Jul 25 '13, 12:19 p.m.

/data01/IBM/WebSphere/AppServer/profiles/AppSrv01/logs/ccm.log:

I looked in this file and saw no entries for yesterday, when I was trying to import.  Do you still want to see the contents?

4 answers



permanent link
KrishnaKanth Naik (7651915) | answered Jul 25 '13, 10:09 a.m.
JAZZ DEVELOPER
hello Ryan

It does sound like a proxy issue, but it would be fair option to increase the Eclipse heap settings to incorporate this import.

As you mentioned that the first instance the error popped up after 20 minutes and then  the next attempt took around 80 minutes, I think you could start with
->  increasing the -xmx parameter in the eclipse.ini file to a higher value
-> or try reducing the size of the import file.

While trying to re-import in your next attempt, you might want to keep an eye on the active services segment in ccm/admin and check for the activities occuring there (wrt team.scm.service.internal.interop.ScmImportService).

Ideally if we need to get onto investigatory mode, I would prefer setting up JazzMon to keep a track of this server (continuously keeps a monitor of this service - than having to keep gazing at the screen for long intervals), but then having smaller dumps to import with higher JVM set to the eclipse client should resolve this problem

Comments
Ryan McBryde commented Jul 25 '13, 11:30 a.m.

Hi,

This is what I was told about the server setup:

In front of CLM (and the other tools) we’ve setup a reverse proxy on the <ip address>  server.


permanent link
Ryan McBryde (341817) | answered Jul 25 '13, 11:30 a.m.

Hi KrishnaKanth,

Thank you for the response.  I think that there is some sort of proxy issue.  Unfortunately I had no involvement in the setting up of the infrastructure.  In this age of specialization, the server was set up by another organization within the company.  The email that I got from them advising me that the CLM server was available said this:

In front of CLM (and the other tools) we’ve setup a reverse proxy on the <ip address>  server.

So it does appear that there is a proxy in there somewhere.

So , I can change the value of the -xmx parameter.  Any recommendations on what it should be?  Is there a danger in setting it "too high"?

How can I go about reducing the size of the import file?  Can that be done to the dump file after it has been created or can in only be done at the time of creation by means of defining what is included?  I ask, because the dump files are created by yet another group within the company.

When you say to keep an eye on the 'active services segment in ccm/admin" are you refering to the admin console that I can get to thru the admin web interface? What am I looking for?

If needed , how would we set up JazzMon?

Thank you again,

Ryan


Comments
KrishnaKanth Naik commented Jul 26 '13, 3:15 a.m.
JAZZ DEVELOPER

increasing the -xmx parameter is a regular practice when you are doing any high data intensive activity using the eclipse client, however there is no known scale that I could recommend you to.

The default value is 512, if you local machine (where you are running the import) has sufficient available memory (lets say 2 GB) - you could increase this value to -XMX 1G or -Xmx 1024M,


KrishnaKanth Naik commented Jul 26 '13, 3:17 a.m.
JAZZ DEVELOPER

I beleive while creating the dump file in svn you should be selecting a query, choose/filter this query to produce a smaller logical dump file. However, this would be my last suggestion, increasing timeout and increasing JVM heaps is a better option.


KrishnaKanth Naik commented Jul 26 '13, 6:57 a.m.
JAZZ DEVELOPER

About active services:

If you are doing a svn import only, this page would let you know all the services that are being invoked for the export and also the status of these services.


If you intend to setup JazzMon, use the video mentioned in this link.


permanent link
Ryan McBryde (341817) | answered Jul 25 '13, 12:13 p.m.

Hi KrishaKanth,

Is this the area in the active services segment that you were referring to?

Screen shot of admin services segment


permanent link
KrishnaKanth Naik (7651915) | answered Jul 26 '13, 3:12 a.m.
JAZZ DEVELOPER
Our comments have character limits.. so let I am answering your questions in different answers...

In that case, you might need to increase the KeepAlive session value for this one activity, I just google'd to check if there are any known issues around this and I found these 2 useful links:

Proxy: Error reading from remote server
PK96410: IBM HTTP Server- intermittent error reading status line with http proxy

What you might want to ask your WAS admins is to experiment the timeout value for Keep alive value in the httpd.conf file of the IHS installation.
===========Default settings in 7.0.x==========
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 15
============================================

If you notice that the import activity is extending for more than the initial error generation time, choose to increase the timeout in regular intervals.

Comments
KrishnaKanth Naik commented Jul 26 '13, 7:15 a.m.
JAZZ DEVELOPER

Increasing the Keepalive and JVM settings should actually fix this issue, but if the issue still persists. Please raise a PMR, we would need to go through the IHS logs and the ccm logs (entire profile/log would be a better idea) to investigate further.

Your answer


Register or to post your answer.