It's all about the answers!

Ask a question

When importing SVN, what causes the error: "Unknown SVN Dump version" ?


Lionel Butler (3635) | asked Jul 09 '12, 6:36 a.m.
edited Oct 12 '17, 12:48 p.m. by David Lafreniere (4.3k7)

Trying to import an SVN Dump into RTC 3.0.1,

Put get the error:   'Unknown dump file version: PK□□□'

SVN Version:  CollabNet Subversion Edge - Windows 32/64-bit Version 3.1.0

Can't find any info on version compatibilty with RTC

Many thanks

Lionel

Accepted answer


permanent link
Lionel Butler (3635) | answered Jul 13 '12, 6:42 p.m.
Having an uncompressed dump file did the trick, the importer is now able to read the dump file.

Have been able to import a Trunk into a RW Component.

Noticed when trying to import an individual branch, the file folder view was missing some branches recently created in SVN Edge (the dump was created afterwards) and was also showing a lot more branches than actually exist on the SVN server. 

Is a SVN Edge dump file different in format to normal svn dump file?

David Lafreniere selected this answer as the correct answer

Comments
Michael Valenta commented Jul 25 '12, 10:13 a.m. | edited Oct 12 '17, 12:49 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

I wouldn't think the dump format would be different. The importer will show all branches that existed over the lifetime of the repo. As to missing branches, I would need more details about the missing branches, specifically, what is the path of the missing branch.

3 other answers



permanent link
Michael Valenta (3.6k3) | answered Jul 09 '12, 2:41 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
The importer only supports version 1 and 2 of the dump file format. I'm not certain but my guess is that the version of subversion you are are extracting the dump from has customized the dump format. This thread (http://subversion.open.collab.net/ds/viewMessage.do?dsForumId=3&dsMessageId=454290) seems to indicate that the dump may be compressed. Try uncompressing it to see if that helps.

Comments
Lionel Butler commented Jul 10 '12, 3:43 a.m.

Thanks Michael I'll ask the Subversion chap to investigate.


permanent link
Tim Mok (6.6k38) | answered Jul 09 '12, 11:05 a.m.
JAZZ DEVELOPER
Have you tried the patch for the importer?

https://jazz.net/wiki/bin/view/Main/SCMImport

Comments
Lionel Butler commented Jul 09 '12, 11:14 a.m. | edited Oct 12 '17, 12:49 p.m.

Yes have already tried, but no difference.

Though I did not find an existing file to replace and the RTC Client was installed with Installation Manager. Based on the step below:

You can put it in the "installDir"/jazz/client/eclipse/plugins directory (where "installDir" is the directory). It should replace an existing file of the same name. Note that this method will only work if you install the RTC client from the zip install (i.e. if you used the Install Manager, it probably won't work).


Tim Mok commented Jul 09 '12, 11:19 a.m.
JAZZ DEVELOPER

Your error message may be due to a bug fixed in the patch. It doesn't seem to be installable if you used IM to install RTC according to the wiki. I would suggest trying a plain zip client and install the patch before trying again.


Lionel Butler commented Jul 09 '12, 12:33 p.m. | edited Oct 12 '17, 12:49 p.m.

Have tried the zip client, and applied the patch successfully, unfortunetly the same error occurs.

Is there a definitive list of which subversion dumps are supported?


Deepti Rao commented Mar 18 '13, 10:01 a.m.

Where do I download the patch?  It does not appear in the above link.  I am getting the similar error ("Unsupported dump file version: 3") trying to import SVN dump using.

$ svnrdump --version
svnrdump.exe, version 1.7.3 (r1242825)
   compiled Feb 13 2012, 17:43:17


Tim Mok commented Mar 18 '13, 10:16 a.m.
JAZZ DEVELOPER

The comment was to try the import with the latest fixes, which isn't relevant anymore. I believe those fixes were backported.

The dump file you've created is in a different format that the importer doesn't support. Did you create a delta dump? Those aren't supported by the importer.

You should also check and update to the latest fixpack for your release just to be sure that you have all the latest importer fixes.


permanent link
Sandeep Anand (1653) | answered Sep 05 '13, 6:43 a.m.
 Hi Lionel,

Can you please help describe how did you uncompress your svn dump file? I am getting the same error message when I try to import an svn dump file into RTC as per the instructions given therein. 

"Unsupported dump file version: 3"

I have a SVN dump file which I have downloaded from the dump repository of apache.org and want to import it into RTC. Any help will be appreciated.

Thanks
Sandeep

Your answer


Register or to post your answer.