It's all about the answers!

Ask a question

When importing a CSV file of work items, what does "Exception: No default timeline found" indicate?


Paul Inman (3516) | asked Jul 21 '15, 6:22 p.m.
We are taking over an incomplete project that was developed under RTC 4.0.6 using the built-in Formal Project Management Process.  I have exported a half dozen work items from the existing project in a 4.0.6 repository using Eclipse into a tab-delimited CSV file.  I have already successfully imported the project template in to an RTC 5.0.2 installation.  When I attempt to import the CSV file using Eclipse, I receive the following message:

An error occurred during import of work items.

Press 'Details' to get more information on the errors.

Readon:
No default timeline found

The Error Log view contains the message "No default timeline found" from the Plug-in com.ibm.team.workitem.rcp.core

Double-clicking on the entry provides the following stack trace:

com.ibm.team.workitem.rcp.core.internal.bugzilla.BugzillaException: No default timeline found
at com.ibm.team.workitem.rcp.core.internal.bugzilla.BugzillaImporter.runImport(BugzillaImporter.java:160)
at com.ibm.team.workitem.rcp.core.internal.bugzilla.BugzillaImporter.access$0(BugzillaImporter.java:141)
at com.ibm.team.workitem.rcp.core.internal.bugzilla.BugzillaImporter$1.run(BugzillaImporter.java:133)
at com.ibm.team.workitem.common.internal.util.Utils.runImport(Utils.java:546)
at com.ibm.team.workitem.rcp.core.internal.bugzilla.BugzillaImporter.doImport(BugzillaImporter.java:131)
at com.ibm.team.workitem.rcp.ui.internal.wizards.inport.WorkItemImportWizard$1.run(WorkItemImportWizard.java:201)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

The project into which I am trying to import the work items does have a default timeline - the same one as the original project, since I imported that project's template.  I included all built-in and custom attributes with the exception of "Id" in the export.

Any ideas?

Thanks,
   -Paul

Comments
Don Yang commented Jul 21 '15, 7:47 p.m.

We did see similar error before and it was caused by default timeline not specified in the project area imported into. You may want to double check if the project area created does indeed have the default timeline.


Paul Inman commented Jul 21 '15, 9:03 p.m.
Yes, the project has a default timeline - the same as the original project, since I imported the same process template.  I also tried expanding the timeline dates to see whether that helped.  Alas, it does not help.  The original project does not even have start and end dates for the timeline.

Taki Nakajo commented Jul 21 '15, 11:04 p.m.

Hi Paul,

I just wonder what the values of "Planned For" in your csv file? Do those values exist in your timeline in the new project area? Can you show us those values and the timeline?


Paul Inman commented Jul 22 '15, 6:25 p.m.

 The values are unassigned.  See the answer I posted (below?).


Accepted answer


permanent link
Paul Inman (3516) | answered Jul 22 '15, 6:23 p.m.
 I have solved the problem, although I do not know the root cause.  I have two different installations of Jazz and RTC: 4.0.6 and 5.0.2.  I have three different configured Eclipse Clients:

 - 4.0.6 based configuration installed using IBM Installation Manager with the Client for Eclipse 3.6.x IDE and the various extensions used for the Rational Team Concert Extension Workshop 

 - 5.0.2 based configuration installed using IBM Installation Manager with the Client for Eclipse 4.2.x IDE and the various extensions used for the Rational Team Concert Extension Workshop

 - 5.0.2 based using Eclipse 4.2.2 with Eclipse IDE for Java EE Developers, PDE, and other extensions, along with RTC 5.0.2 installed from the p2 repository

I mostly use the latter for various projects as it has lots of the tools I use.  However, it is the one I was using that failed to import the CSV file from the 4.0.6 configuration.  When I tried the import today using the 5.0.2 configuration installed using Installation Manager, it worked fine.
Geoffrey Clemm selected this answer as the correct answer

Comments
Paul Inman commented Jul 22 '15, 6:26 p.m.

 I'm sure it's staring me in the face, but how do I mark this as "solved"?

Your answer


Register or to post your answer.