It's all about the answers!

Ask a question

How to add a testing tool to the team area preconditions


marco Kaiser (2311313) | asked Jul 24 '13, 8:33 a.m.
edited Aug 01 '13, 9:27 a.m.
Hello guys,

Client: MS Visual Studio 2013
RTC Version: 4.0.3

we try to set up an testing tool to the preconditions of a team are. The problem is, that we don't get the tool start. The settings are as in the picture. Do you have an manual how to set up tools in the preconditions?

I'm looking forward to your answer.

Marco

Settings Error

Comments
Millard Ellingsworth commented Jul 24 '13, 4:24 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

It seems you have written and contributed your own Precondition to add here? I tried to duplicate what you did here, but I don't have that precondition available. What reference did you use for writing/contributing your precondition? (FTR, I don't have a VS Client but was trying to check on Eclipse.) 

2 answers



permanent link
Ralph Schoon (61.5k33643) | answered Jul 25 '13, 1:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Marco,

there are server and client extensions. Server extensions run in the server, client extensions in the client. Some more explanations can be found here: http://rsjazz.wordpress.com/2013/03/14/what-apis-are-available-for-rtc-and-what-can-you-extend/

Now, you are using the Eclipse client to configure the process and it will have all pre-conditions available. However, they are not all available for the VS Client. You can not see what is available in VS and what is not. (Consider to create an enhancement request for this.) If you configure a client precondition and that is not available to Visual Studio, you get the error you see above. The options would allow you to block the operation in this case.

Unfortunately I am not aware of any way that would allow you to create client extensions for the Visual Studio Client. I think we don't even have a VS client SDK. Again, consider requesting an enhancement.

Comments
marco Kaiser commented Jul 30 '13, 3:13 a.m. | edited Jul 30 '13, 1:34 p.m.

Hello guys

Thanks for your answers.

@Millard: The precodition we choosed was as followed:

precodition setting

The user changed the name to the name diplayed in my first message.

@RSchoon: The tool we choosed is fo VS. (See screenshot).

Could you contribute a manual how to set up such a tool fo VS or which settings have to be observed during the set up?

Thanks you again!

Kind Regards

Marco


permanent link
Stephane Leroy (1.4k149) | answered Jul 30 '13, 5:24 a.m.
JAZZ DEVELOPER
Hi Marco,

here is the material I'm aware about:
  • [Jazz.net article] https://jazz.net/library/article/591/ (for RTC 3.0 version)
  • [4.0.3 InfoCenter] http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?topic=%2Fcom.ibm.team.concert.dotnet.doc%2Ftopics%2Ft_static_analysis.html
The last resource gives a precise example in its section 8.  "To use a custom tool, complete the following steps".
I'd advise you read it very carefully to figure out where the root cause of your problem stands (parameters, etc.)

Regards,
Stéphane


Comments
marco Kaiser commented Jul 31 '13, 10:05 a.m.

Hi Stéphane,

thanks for you advice.
We tried to set up MS FXCop as described in the example. When the "Fail if not installed" mark is set, we get some errors. Is the mark mandatory?
When we don't mark "Fail if not installed" it seems that the precondition is not used.

Beside this, we have two questions for integration custom tools:

  • Which specific requirements are necessary for the costume tools to be embedded into the preconditions? Are there interfaces (for example API) which have to be used if writing an test tool.
  • Are there some arguments which have to be set in the preconditions when setting up a tool?
Thanks for your answer!

Kind Regards
Marco


1
Ralph Schoon commented Jul 31 '13, 10:17 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

"Fail if not installed" would fail if the precondition is not installed in the client you use. In this case in the Eclipse client. If there is a failure in Visual Studio when you check this, there is probably an issue with the way the client is set up e.g. MS FXCop not available - just a guess.


marco Kaiser commented Aug 01 '13, 4:54 a.m.

Hi Ralph,

the issue is, that we get two differend errors when delivering. The first if whe have set the wrong path to the tool loction and the second if we set the "Fail if not istalled" setting (in this case we choosed the right path).

1st: path wrong: Error when path wrong

2nd: path right but "Fail if not installed" set: Error when "Fail if not installed" set

When we don't choose the "Failure if not installed" condition, the check-in runs without error.

What is the reason that we get two different erros and why does it work when don't choose the precontion? How does the jazz server work with this precondition and is it necessary that the precondtion (for example "Require Static Analysis Run (...)") is installed on the server?

Regards

Marco


Ralph Schoon commented Aug 01 '13, 8:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I am assuming this in the MS VS client. The second error indicates that the RTC Visual Studio Client does not have the operational behavior installed. So it can't call it. There is either a defect in the advisor or something else is wrong. Hard to tell. I'd consider to create a defect at https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWelcome

I am assuming the MS VS client installed has a version matching the Eclipse client you used for configuration,


Jared Burns commented Aug 20 '13, 2:40 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Marco, did you ever figure out what was happening? 


marco Kaiser commented Sep 10 '13, 4:24 a.m.

Hi Jared,

we didn't get it to work until now. We opended the Defect 275094 for this issue. This is to be fixed in 4.0.5

Greetings Marco


marco Kaiser commented Oct 22 '13, 7:12 a.m. | edited Oct 22 '13, 7:13 a.m.

Hi Jared,

Our Workaround was to use Jenkins to call the testing tool. So Jenkins calls the tool which works perfectly.

Greetings Marco

showing 5 of 7 show 2 more comments

Your answer


Register or to post your answer.