It's all about the answers!

Ask a question

scm.ini options for Visual Studio


Eddie Breeveld (6112230) | asked Nov 29 '13, 5:34 p.m.
retagged Dec 13 '13, 2:21 p.m. by David Lafreniere (4.5k7)
I am using the Visual Studio plug-in to load a large workspace from a remote Jazz server.  Unfortunately the data rate is very slow, and after an hour or so the connection times out.
Is there an option I can add to the scm.ini file to increase the timeout to (say) a whole day instead of an hour?
Are the scm.ini options documented anywhere?

2 answers



permanent link
Karl Weinert (2.0k52636) | answered Dec 02 '13, 11:23 a.m.
JAZZ DEVELOPER
The properties for the repository connection should have the "connection timeout" option similar to the one in eclipse.
Right click the repository connection and choose properties.


Comments
Eddie Breeveld commented Dec 02 '13, 11:50 a.m.

Thank you - unfortunately this is set to 480 (8 minutes), which does not seem to be the problem.  I'll have to look elsewhere.


Karl Weinert commented Dec 02 '13, 12:00 p.m.
JAZZ DEVELOPER

Hi Eddie
That could still be the problem, try setting it to 9999 and see if that helps.
The basic way the load works is, after each file is downloaded the time out is reset
So the problem could be one large file that is taking more than 8 minutes to download


permanent link
Eddie Breeveld (6112230) | answered Dec 05 '13, 9:11 a.m.
edited Dec 05 '13, 9:14 a.m.
Thanks Karl,
I eventually found the issue - the timeout does help, but it was the 32-bit scm.exe that Visual Studio uses was the killer - it cannot cope with huge (GByte) files even with the java heap set to 1.5GBytes.  Using Eclipse and setting its java heap to 6GBytes is the only work-around I have found.  It does not help that we have a very slow connection to the server too.
Eddie

Your answer


Register or to post your answer.