It's all about the answers!

Ask a question

Cannot remove an artifact from a module


Stephen Toop (10111822) | asked Jul 02 '13, 10:17 a.m.
RRC 4.0.1

We have disabled Delete Artifact and Delete Folder permissions for our users.

However we have since discovered (and proved) that this now prevents the user from removing an artifact from a Module.
Is this expected behaviour?
I would see the action of removal from a module being a "Modify" rather than a delete.
We are not trying to delete the Module or the base artifact.

Anyone seen this?
Any workaround?

Thanks
Stephen Toop

One answer



permanent link
Mike Jaworski (1.4k6) | answered Jul 02 '13, 10:43 a.m.
JAZZ DEVELOPER
 Stephen,

I think I understand what's happening. In RRC, the artifacts displayed within a module are actually referred to as "Module Artifacts", and even though they only appear as a pointer to the base artifact, they are actually distinct entities which contain distinct information such as comments and links which are separate from the base artifact. Because these Module Artifacts are distinct artifacts, the "Remove" operation within the Module is actually performing an under-the-covers delete on the Module Artifact (not the base artifact), which is most likely being prevented by the lack of delete permissions which you've specified.

I probably wouldn't disagree with you if you wanted to consider this as a defect, since it makes sense that Module Artifact removal should probably be considered as a distinct operation. It actually looks like a defect was recently created for something similar to this: 

Mike Jaworski

Comments
Aaron Cabrera commented Feb 10 '14, 11:36 a.m.

In Release 4.0.5 - When I am in a module that contains multiple artifacts - one of the options available to me is to "Remove Artifact". I am then presented with additional options - "Remove and Delete", "Remove" and "Cancel".

How do I set the permissions to allow the "Remove" only without giving them the permission to "Delete" a module?

Your answer


Register or to post your answer.