It's all about the answers!

Ask a question

How can I report RRC Data without MS Word encoding; not using the Heading of RRC as Heading in MS Word


Erwin Kunz (94686284) | asked Jun 18 '13, 10:22 a.m.
edited Jun 27 '13, 11:24 a.m.
RRC 4.0.2
RPE1.1.2.2

I have created a RRDG (using RPE) template to report a selection of artifacts to Word with a word style-sheet.. All went well as long as I didn't use Format: Heading.

When creating a report it mess up the result. Word does interpret the Headings from the artifact, as word heading.

e.g the artifact


end up in Word as


Any Idea how i could disable the handling of Metadata in RPE/RRDG

Accepted answer


permanent link
Guido Schneider (3.4k1383110) | answered Nov 19 '13, 4:37 p.m.
Use "heading level offset"  e.g. as 10.
This is a property of the template element. To do this Open studio, select the element that renders the data (CONTAINER), go to the properties view, expand the “Formatting - Common - heading level offset)
section and set this property.
Erwin Kunz selected this answer as the correct answer

Comments
Erwin Kunz commented Nov 20 '13, 3:03 a.m.

Thanks Guido

I did test your proposal and it works fine

One other answer



permanent link
Abish Mathew Zachariah (252211) | answered Jun 20 '13, 2:03 a.m.

Hi Erwin

How did you create these numbered headings in RRC Rich text editor?

I can give different heading styles in RRC RTF editor using the ‘Format > select appropriate heading level’ but could not find a way to have numbered headings without manually typing the numbers or use ‘Numbered list’. Let me know.

Also, when you say you have applied heading styles in RPE, I presume you have applied the style > Heading Styles > (1,2,3,…) for this paragraph which extract artifact text information.

The best way to handle these scenarios is to use a stylesheet (.dot or .doc) file in RPE which has the different heading level numbered. For example .dot file rpe.dot in location “%RPE_HOME%\utils\word”. So in this case RPE will get the heading styles from RRC and the numbering will be applied using the stylesheet. I have tried and it’s coming as expected. But as I have mentioned above , if you have applied manual numbering for those different headings in RRC RTF editor, then this will lead to duplicate heading numbers in the RPE generated Word document.

Best Regards
Abish M Zachariah


Comments
Erwin Kunz commented Jun 20 '13, 2:58 a.m.

Hi Abish
the Numbering in RRC is manual, and should not be be issue. We can look at the scenario without those numbers.

No I used the Heading Style in RRC

I have a template myreport.dot which has all the style definition for the Heading. An that is my Issue. Each artifact should have Heading 2, an the content should be below
as follow


Unfortunately the style sheet does interpret the Heading from RRC. See picture above with yellow numbering. I nee to be able to say to RPE/Word "this part is to be taken as is".

BTW: I do not run the report using RPE Launcher, but integrated in RRC (RRDG)


Erwin Kunz commented Jun 26 '13, 4:20 a.m.

@schneidg : test if (at) works


Abish Mathew Zachariah commented Jul 02 '13, 8:21 a.m.

Hi Erwin

Thanks for the update. As I understand, you want RPE to number only the first two headings in the artifact as shown in your screenshot and ignore the rest of the headings in the artifact text.

By default RPE is instructed to follow the heading styles that are exposed by the data source. Either you can ignore all those heading styles or follow that completely in RPE. Here RRC REST API exposes those heading styles along with the artifact headings and hence RPE retains that in the generated output along with the numbers defined in the stylesheet.

I have run the report from RPE. The behavior should be the same from RRC using RRDG. I will also check if there are any other options to achieve your requirement.

Best Regards
Abish M Zechariah


Erwin Kunz commented Jul 05 '13, 4:20 a.m. | edited Jul 05 '13, 4:24 a.m.

Hi Abish

Thank you for the follow up. 
Writing question/bugs is always difficult :-(

<<you want RPE to number only the first two headings in the artifact >>
No RPE should do nothing with the artifact content. Just display as is.
Format(bold/size) as is.

<< Either you can ignore all>>
I would also be happy with this. How can I tell RPE to ignore the style

As i wrote to Will in the PMR: this issue is also with standard report delivered with RRC. A Heading in RRC Artifact appear in the table of Content of the generated Word report. What in my opinion is near a Bug :-)
Best would be to be able to map the RRC Headings with Stylesheet Headings by yourself
erwin

Your answer


Register or to post your answer.