It's all about the answers!

Ask a question

[closed] can`t log on to jazz team server !


1
1
Mai Saad (11134) | asked Apr 14 '13, 7:45 a.m.
closed Nov 18 '16, 5:54 a.m. by Ralph Schoon (57.1k23642)

- I `ve installed jazz team server from RTC-Web-Installer-win-4.0 using IBM installation manager , then  i start server and try to create new jazz repository connection using RTC visual studio client , using URI https://localhost:9332/ccm/ , ID : "ADMIN" , password "ADMIN" then i got this error:

CRRTC8521E: Failed to contact the repository 'ADMIN@localhost'

- notes : i`m using windows 7 .

- server o/p :

Apr 14, 2013 11:21:30 AM org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performanc

e in production environments was not found on the java.library.path: C:\Users\Ma

i\Desktop\RTC4\server\jre\bin\compressedrefs;C:\Users\Mai\Desktop\RTC4\server\jr

e\bin;C:\windows\system32;C:\windows;C:\Program Files\Common Files\Microsoft Sha

red\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Li

ve;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\W

indowsPowerShell\v1.0\;C:\Program Files (x86)\Windows Live\Shared;C:\Program Fil

es (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.

0\bin\x64;C:\Program Files (x86)\Toshiba\Bluetooth Toshiba Stack\sys\;C:\Program

 Files (x86)\Toshiba\Bluetooth Toshiba Stack\sys\x64\;C:\Program Files\doxygen\b

in;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\CVSNT\;.

Apr 14, 2013 11:21:33 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["http-bio-9080"]

Apr 14, 2013 11:21:33 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["http-bio-9443"]

Apr 14, 2013 11:21:34 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["ajp-bio-9009"]

Apr 14, 2013 11:21:34 AM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 4724 ms

Apr 14, 2013 11:21:34 AM org.apache.catalina.core.StandardService startInternal

INFO: Starting service Catalina

Apr 14, 2013 11:21:34 AM org.apache.catalina.core.StandardEngine startInternal

INFO: Starting Servlet Engine: Apache Tomcat/7.0.25

Apr 14, 2013 11:21:34 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\admin.war

Apr 14, 2013 11:21:41 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\ccm.war

Apr 14, 2013 11:22:13 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\clmhelp.war

Apr 14, 2013 11:22:36 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\converter.war

Apr 14, 2013 11:22:46 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\jts.war

Apr 14, 2013 11:22:59 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\qm.war

Apr 14, 2013 11:23:20 AM org.apache.catalina.startup.HostConfig deployWAR

INFO: Deploying web application archive C:\Users\Mai\Desktop\RTC4\server\tomcat\

webapps\rm.war

log4j:ERROR Could not find value for key log4j.appender.perfCounters.layout

Apr 14, 2013 11:23:31 AM org.apache.catalina.startup.HostConfig deployDirectory

INFO: Deploying web application directory C:\Users\Mai\Desktop\RTC4\server\tomca

t\webapps\ROOT

Apr 14, 2013 11:23:31 AM org.apache.coyote.AbstractProtocol start

INFO: Starting ProtocolHandler ["http-bio-9080"]

Apr 14, 2013 11:23:31 AM org.apache.coyote.AbstractProtocol start

INFO: Starting ProtocolHandler ["http-bio-9443"]

Apr 14, 2013 11:23:31 AM org.apache.coyote.AbstractProtocol start

INFO: Starting ProtocolHandler ["ajp-bio-9009"]

Apr 14, 2013 11:23:31 AM org.apache.catalina.startup.Catalina start

INFO: Server startup in 116808 ms

anyone know why can`t log on server ??

thanks alot.


Comments
Mai Saad commented Apr 14 '13, 7:51 a.m. | edited Apr 14 '13, 8:05 a.m.

- I tried to ping on server using the URI https://localhost:9443/jazz/ or https://localhost:9332/ccm/

but ping request couldn`t find that URI telling me to check name and try again

- is there away to check server uri after installation ?

The question has been closed for the following reason: "Problem is not reproducible or outdated" by rschoon Nov 18 '16, 5:54 a.m.

7 answers



permanent link
Bo Chulindra (1.3k2718) | answered Apr 15 '13, 2:46 p.m.
JAZZ DEVELOPER
edited Apr 15 '13, 3:13 p.m.
There seems to be quite some confusion going on here. Let me explain a bit:

When you install your RTC server, it will generally consist of two apps, CCM and the JTS (though from the tomcat console output you pasted above, I see you installed all the CLM products, which consists of JTS, CCM, QM, and RM) . After installing, you should visit https://localhost:9443/jts/setup to setup the JTS, register CCM, and setup CCM. Your login will be ADMIN/ADMIN.

You can also register and setup QM and RM if you wish but it is not necessary if you only want to try out connecting your RTC client.

After finishing setup, you can then connect your RTC client to your CCM. The URL you will use for your connection is https://localhost:9443/ccm. Note that you may have disabled the ADMIN user during setup. If so, you will have to provide a username and password for the user you created during setup.

Your problems above were that you were either using the wrong port (https://localhost:9332/ccm) or the wrong context root (https://localhost:9443/jazz) or you added extra which shouldn't have been there (https://localhost:9443/ccm/admin).

I use "localhost" in the URLs I provided above, but this will only work if the server is on the same machine as your client. If you are setting this RTC up as a production server, you will definitely need to learn more on the proper way to set one up.


Comments
Ralph Schoon commented Apr 15 '13, 5:09 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks Bo!


Mai Saad commented Apr 16 '13, 5:42 a.m. | edited Apr 16 '13, 5:44 a.m.

@ Bo : thanks alot for reply , i visited https://localhost:9443/jts/setup to setup the JTS and it gave me warning for using localhost in uri and if i changed it and test connection ..it gives error so i continued on localhost (in this case i couldnt test connection because of  previous warning) and completed settings but when try to access from client it gave me error , anyway im installing new server + client and `ll care by this setup ...hope it works !


1
Bo Chulindra commented Apr 17 '13, 12:08 p.m.
JAZZ DEVELOPER

You cannot connect the client to the JTS. You must connect it to the CCM. Use https://localhost:9443/ccm as the URL for your repository connection from the RTC client.

I highly doubt the problem will be solved by installing a new server and client. You must follow the instructions I provided exactly.

Here's some more explaining:

  • It is not recommended to use "localhost" for your public URI. However, if you are just testing out a server, it is fine.
  • If you do not want to use "localhost" for your public URI, you must provide a real host name to your server. You cannot just make one up. If you are not sure what I mean, then just use "localhost".
  • The only application you can connect to with your RTC client is the CCM. The JTS is NOT the CCM. If your public URI you entered during setup is https://localhost:9443/jts, then the URI for CCM is NOT https://localhost:9443/jts. It is likely https://localhost:9443/ccm.


2
Bo Chulindra commented Apr 17 '13, 12:08 p.m.
JAZZ DEVELOPER

Mai Saad commented Apr 18 '13, 4:39 a.m.

@ Bo : you are right , after installing the new server + client , then trying to log on server using jts or ccm but on 9332 was huge mistake , i`ve just tried to access server from client using ccm on 9443 , it works , many thanks Bo.

but i`ve 2 other issues now

1-when setting e-mail configurations using https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_s_server_installation_setup_wizard.html&scope=null

to enable mail invitation , i needed to set some values ,are these values correct ?

SMTP Server name (smtp.localhost.com)

SMTP Username (same as jazz server ID )

email from address (name@localhost.com)

as when i use these values then test connection it gave me : Exception reading response;nested exceptionis : java.net.socketTimeoutException: Read time out , any ideas ?!

2- what do u mean exactly by real host name  ?


Bo Chulindra commented Apr 18 '13, 10:31 a.m.
JAZZ DEVELOPER

Mai,

For choosing a host name for your public URI, see Planning Your URIs. If you are still confused, search the forum or open a new forum question and people may be able to explain it better.

For your email configuration, it looks like you are trying to configure the RTC server itself as the SMTP server. This won't work. The RTC server is not a SMTP server. You will need to configure the settings for an SMTP server. I don't know enough about the matter to explain it better, but when I just want to test the email function of RTC, I use Gmail as my SMTP server. Feel free to search the forum or open a new forum question if you want more info.

showing 5 of 6 show 1 more comments

permanent link
KrishnaKanth Naik (7651915) | answered Apr 14 '13, 3:03 p.m.
JAZZ DEVELOPER
Hello Mai

In you last comment you have mentioned that you tried accessing on 2 URI's:
https://localhost:9443/jazz/ or https://localhost:9332/ccm/

Also that you have installed RTC 4.0.

If this is a fresh instance of RTC on Tomcat and considering that you have not yet updated any config files, you should be accessing the server on:
https://localhost:9443/jts/setup
or
https://localhost:9443/jts/admin
or
https://localhost:9443/ccm/admin

If you are able to get to the Login screen, and the user ID ADMIN with the same password is not working, you might want to check the permission with which you have installed the JTS server. The reason why I ask this is because the choice of the installation directory as "C:\Users\Mai\Desktop\RTC4\" is a bit strange. Did you try installing the server without Admin privileges?

In Windows 7, due to the default security rules being on (UAC) you would need to install the application running as a administrator.

Comments
Mai Saad commented Apr 15 '13, 3:56 a.m. | edited Apr 15 '13, 2:39 p.m.

Hello Krishnakanth

thanks alot for reply,

i`ve just tried mentioned addresses , pinging server gives same result while creating new jazz repository connection results in new error : CRRTC8500E

details:

Exception type:

com.ibm.team.repository.TeamRepositoryException

Exception message:

Failed to log in to 'https://localhost:9443/ccm/admin/': CRJAZ2384E Cannot connect to the repository at URL "https://localhost:9443/ccm/admin", see the nested exception for more details. For more details, open the help system and search for CRJAZ2384E.

Inner exception:

Exception type:

com.ibm.team.repository.TeamRepositoryException

Exception message:

CRJAZ2384E Cannot connect to the repository at URL "https://localhost:9443/ccm/admin", see the nested exception for more details. For more details, open the help system and search for CRJAZ2384E.

Status code:

500

Remote exception type:

com.ibm.team.repository.common.TeamRepositoryException

Request URI:

http://localhost:1033/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/Login

Inner exception:

Exception type:

com.ibm.team.repository.TeamRepositoryException

Exception message:

invalid UUID [<!DOCTYPE html>]

Status code:

0

Remote exception type:

java.lang.IllegalArgumentException

Request URI:

http://localhost:1033/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/Login

- about installation as admin , im not sure about it , so i think
</pre>
<pre dir="LTR">
 ill re-install it !


KrishnaKanth Naik commented Apr 16 '13, 3:36 a.m.
JAZZ DEVELOPER

Hello Mai

This might need some troubleshooting, please open a support ticket.

From your previous post it seems that the access ports have been changed to 1033.
Request URI:
http://localhost:1033/service/com.ibm.team.filesystem.client.rest.IFilesystemRestClient/Login

Hence when you try to access "https://localhost:9443/ccm/admin" you are getting Status code:500


** Apologies for the bold font, there seems to be something wrong in the comment window


Mai Saad commented Apr 17 '13, 7:15 a.m.

@ Krishnakanth : after new installation the access ports have been changed to 1042 !!


KrishnaKanth Naik commented Apr 17 '13, 7:25 a.m.
JAZZ DEVELOPER

@Mai

I am more confused now. In very comment there are different port numbers being mentioned. 

Question:
1) Did you setup the public uri using port 1042?
2) Did you use the hostname as localhost while running jts/setup?
3) Are you trying to access JTS server from your VS client on the same machine?


Ralph Schoon commented Apr 17 '13, 7:30 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This all does not makes much sense. I assume you are running on Tomcat, correct? If you do, you are the one who has to specify the ports to be used by Tomcat in the Tomcat/conf/server.xml the default port is 9443 unless you explicitly change them by editing the entries. 

If you install on WAS, you will automatically get a new port with each profile you create. In that case you have to make sure to use the port provided with the profile when you specify the Public URI.


Mai Saad commented Apr 17 '13, 8:02 a.m.

@ krishnakanth : i`m confused too , i never met thing like this before , actually the whole scenario is new for me .

answers :

1- i didn`t change any ports while setup.

2- yes i used it on the Configure Public URI page and tried it too from vs client.

3- yes i do , is there any problem in this ?


Mai Saad commented Apr 17 '13, 8:11 a.m.

@ Ralph :

yes i`m using Tomcat , i didn`t change any ports in Tomcat/conf/server.xml when i opened it i found :

connector port = 9080 , redirect port = 9443, connection timeout = 20000 , protocol = http/1.1 then in other line connector port = 9443 ,connection timeout = 20000, protocol = http , ciphers = ssl_rsa_with_rc4_128_md5 then in other line connector port = 9009 , redirect port =9443 , protocol = AJP/1.3 ,enablelookups= false

showing 5 of 7 show 2 more comments

permanent link
Ralph Schoon (57.1k23642) | answered Apr 15 '13, 4:38 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
A frequent error on Windows systems especially Windows 7 is to choose the default path into Program Files. If you do that, you have to run the server startup as administrator with run as administrator explicitely, or else Tomcat does not have permissions to create files and folders.

Best is to install somewhere else e.g. c:/clm4.0.1/

Comments
Mai Saad commented Apr 15 '13, 4:53 a.m.

@ Ralph : i already changed the default directory to "C:\Users\Mai\Desktop\RTC4\" but it didn`t work .


Mai Saad commented Apr 16 '13, 5:46 a.m.

@ Ralph : thanks alot .


permanent link
Mai Saad (11134) | answered Apr 17 '13, 5:19 a.m.
edited Apr 17 '13, 6:22 a.m.

@ all : i`ve installed new server (express server) and client , i made setup to server from https://localhost:9443/jts/setup but i`ve some questions :

1- In server installation (express install) ,i got warning that OS not supported but can work for small scale , i`m using windows 7 could this affect server access?

2- in server setup , using URL https://localhost:9443/jts/ gives warning CRJAZ1580W and couldn`t allow me make test connection , is it aproblem for small team (10 developers) ?

3-in server setup when changing the URL to https://rclm.test.com:9443/jts/ , it results in error CRJAZ1579E , do you have any idea about it ?

4- after what mentioned in 1 , i could visit https://localhost:9443/ccm. with new user name and password , but still i can`t create repository connection from visual studio client using URI : http://localhost:9443/ccm/admin or https://localhost:9332/ccm , name : my new name , ID : new id from server setup and new password (still having same error CRRTC8500E ,CRJAZ2384E ) and still ping server using tps://rclm.test.com:9443/jts  didn`t work  (please check the name and try again) , so i tried to invite myself in project from web client but seems i must first configure email settings https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.jazz.platform.doc/topics/t_logging_in_application_administration_page.html&scope=null  ...in email settings need SMTP Server, do i need install this server ?!

thanks


Comments
Mai Saad commented Apr 17 '13, 5:54 a.m. | edited Apr 17 '13, 5:54 a.m.

Hello Krishnakanth

if i still need to open a support ticket after new installation , can you please guid me how to open it ?

thanks


KrishnaKanth Naik commented Apr 17 '13, 7:34 a.m.
JAZZ DEVELOPER

@Mai

You could mail any of the following email IDs with the issue that you are facing (along with your IBM customer number) to (depending on which region you belong to):
For EMEA support: sw_support_emea@nl.ibm.com
For US Support: sw_support@us.ibm.com
For AP Support: sw_support_ap@au1.ibm.com


Bo Chulindra commented Apr 17 '13, 3:06 p.m. | edited Apr 17 '13, 3:11 p.m.
JAZZ DEVELOPER

[.deleted]


permanent link
Ralph Schoon (57.1k23642) | answered Apr 17 '13, 8:20 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
If you use the standard setup, not distributes, with the standard ports the URL's are as already mentioned

https://<hostname>:9443/jts
https://<hostname>:9443/ccm

Note: you can't run more than one Tomcat on one machine with the same ports - they would collide and you could only reach the one that grabbed the port first. You can check who has which port with netstat.
Note: if just on one machine localhost works,otherwise use a global host name
Note: Some companies block ports. You can change 9443 to 443 which is the well known port for https.


Comments
Mai Saad commented Apr 17 '13, 11:15 a.m. | edited Apr 17 '13, 11:16 a.m.

@ Ralph : - i tried netstat ,i notice that the port 9443 don`t appear in in/out even if tomact is running , but when i log on web client this port appear in both in/out so this means web client can see server (the other clue is that when close server and try web client , it fails) so seems the problem in connection fron vs client to server .

- changing port to 443 didn`t make difference in vs and server area !


Ralph Schoon commented Apr 17 '13, 11:23 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I closed all my severs and clients. I ran netstat - a and port 9443 was nowhere to be seen. I started a Jazz Team Server and ran netstat -a and 9443 was listed as listening.

When I mentioned using 443 I meant changing the default ports used in the server.xml and then start and configure the server. In which case you don't need to provide the port in the URL any longer - because it is well known.

See http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers for what that is and https://jazz.net/library/article/831 for all you need to know about administration of Jazz - well, the very basics in a not trivial environment.


permanent link
Mai Saad (11134) | answered Apr 18 '13, 4:48 a.m.
edited Apr 18 '13, 10:13 a.m.

@ all : many thanks for your help ,

i finally could create new repository from visual studio client with the following solution :

- installing new server and client in administartor mode , using c:/RCLM4-SERVER for server , c:/RCLM4-CLIENT for client , c:/RCLM-SHARED for client shared files.

- after start server configure it according to https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_s_server_installation_setup_wizard.html&scope=null using URI : https://localhost:9443/jts/setup , user name and pw are ADMIN , while setup i changed those user name and pw to new ones .

- create new project using previous web client .

- create new repository from vs client using uri : https://localhost:9443/ccm , using name localhost,  new ID and PW during server setup .

my problem now as i told Bo in configuring email settings

1-when setting e-mail configurations using https://jazz.net/help-dev/clm/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_s_server_installation_setup_wizard.html&scope=null

to enable mail invitation , i needed to set some values ,are these values correct ?

SMTP Server name (smtp.localhost.com)

SMTP Username (same as jazz server ID )

email from address (name@localhost.com)

as when i use these values then test connection it gave me : Exception reading response;nested exceptionis : java.net.socketTimeoutException: Read time out , any ideas ?! this after installed free smtp server.

while without smtp server it gave me : couldn`t connect to smtp.localhost.com , port 25 , response -1


Comments
Mai Saad commented Apr 28 '13, 7:09 a.m.

SMTP server problem solved using server name 127.0.0.1or just local host as mentioned in https://jazz.net/forum/questions/110460/how-to-connect-jazz-server-to-smtp-server


permanent link
Princi Verma (287) | answered Nov 18 '16, 5:28 a.m.
 Hi,

I am trying to move my plugin from RTC 4.0.1 to RTC 5.0.2. In this after running my RTC Eclipse Client through Run Configuration it's not allowing me to connect to the repository "https://localhost:7443/jazz". It shows me the following error-
CRJAZ2383E Cannot connect to the repository at url "https://localhost:7443/jazz".

And when I am trying to run server.startup.bat file from JazzTeamServer\server folder to connect to localhost "https://localhost:9443/jts/setup" as mentioned in "IBM RTC Extensibility4.x pdf" at page number 23 then it get closed automatically.

Please assist...

Comments
Ralph Schoon commented Nov 18 '16, 5:55 a.m. | edited Nov 18 '16, 5:56 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 This question was from over 3 years ago and not even remotely related to your question. If you have a question, ask it in your own question.


Princi Verma commented Nov 18 '16, 6:07 a.m.

 ok... thank you Ralph...