It's all about the answers!

Ask a question

"CRRDV0015E The report query results cannot be displayed" and "Error initializing reports service" error messages


Anthony Paul (7021721) | asked Mar 27 '13, 10:03 a.m.
retagged Apr 01 '13, 1:05 p.m. by Lisa Caten (342913)
 Hi,

We noticed our WebSphere service on AIX was been run as root. So we changed the permissions on WebSphere and the Jazz Team Server directory to be writeable by a user named was and started the WebSphere service as this user. 

It all seemed to work but when I logged into RQM all the widgets on the dashboard displayed this error:

CRRDV0015E The report query results cannot be displayed. The server encountered an unexpected error that prevented it from retrieving the report query results. To find more details about this issue, open the JavaScript console of your browser by pressing F12, refresh the widget, and check the JavaScript console for any resulting errors.Loading...

and if I try run a report manually I get:

Error initializing reports service

When we stopped WebSphere and started it as root again, it all worked perfectly. 

Any ideas on how to fix this?

WebSphere is running at version 7.0.0.23
and 
RQM is 4.0

Thanks

Comments
Brian Lahaie commented Sep 09 '15, 2:52 a.m. | edited Sep 18 '15, 11:40 a.m.

I was getting the same error in my dashboard widgets.  To resolve the issue I did the following:

(1)I stopped the server

(2)Deleted the following directories:
C:\IBM\JazzTeamServer60\server\tomcat\work\Catalina\localhost\qm
C:\IBM\JazzTeamServer60\server\tomcat\work\Catalina\localhost\ccm
C:\IBM\JazzTeamServer60\server\tomcat\work\Catalina\localhost\jts

(3)And then started the server.

After deleting the directories and restarting the server, the widgets started to display data again.

Accepted answer


permanent link
Sandy Grewal (1.6k1123) | answered Mar 27 '13, 1:09 p.m.
JAZZ DEVELOPER
@Anthony, please open the qm/admin >Advanced Properties  find "Reports Temp Folder" this is usually not defined. It defaults to the java.io.tmpdir of the JVM
Set this property to an existing directory that is writable by the user running the WAS instance.

Set this for both jts/admin and qm/admin. Restart.
If you are running CCM you will need to do it for that too.
Anthony Paul selected this answer as the correct answer

Comments
Anthony Paul commented Mar 27 '13, 1:35 p.m.

Many thanks I will give this a go and let you know how we get on.


By the way what is the default location for java.io.temp and can that value be changed. 


Sandy Grewal commented Mar 28 '13, 1:33 p.m.
JAZZ DEVELOPER

This would depend on your environment, WAS could be setting it too in its startup.

Searhing the web, found the following.
the JVM initializes it to a platform specific default value. For Windows, the default is obtained by a call to a Win32 API method. For Linux / Solaris the default is apparently hard-wired. For other JVMs it could be something else.

If you really wanted to find out, you would have to run code on the running WAS JVM and check the result of the following.
System.getProperty("java.io.tmpdir");


Sandy Grewal commented Mar 28 '13, 1:39 p.m.
JAZZ DEVELOPER

It can be changed by specifying the argument like -Djava.io.tmpdir=/tmp in the WAS JVM's Generic JVM arguments


Anthony Paul commented Apr 03 '13, 5:45 a.m.

Hi many thanks your fix worked. Changed the properties of "Reports Temp Folder"  to a new temp folder and now the reports and widgets work when running the service as the was user. 

What we found was that it was using /tmp as its temporary folder and creating directories such as :
reports_tYCTYueDEeGLNqqfpzGBLQ
These were created as root (when we ran the WebSphere service as root) and when we restarted the service as the was user it was still trying to use these folders.
When we changed the temporary directory and restarted the WebSphere service these directories were recreated in the new temp folder and as was as the owner.

Your answer


Register or to post your answer.