It's all about the answers!

Ask a question

repotools-jts export data problems


Francis Kemp (7212334) | asked Feb 25 '13, 11:38 p.m.
I'm trying to move the database of a Jazz installation (CLM 4.0.1) from Derby to DB2.  This is something I've done several times before.  This time, however, the files generated by 'repotools-[jts|ccm|qm] -export' are much smaller than you would expect them to be for the amount of data in the database. When I tried to restore the output file to DB2, there was no data in the database.

Fortunately, I backed up everything before I attempted the move, so I was able to put the original configuration back together again. 

Has anyone ever seen this behavior?


Thanks,
Fran

Accepted answer


permanent link
Bo Chulindra (1.3k2718) | answered Feb 26 '13, 4:53 p.m.
JAZZ DEVELOPER
It's a known issue that when the Derby database location is relative, the server does not use JAZZ_HOME to calculate the absolute path. That ends up meaning that when the container is WAS, the absolute location ends up being in the WAS profile.

The help doc for deploying CLM on WAS mentions that the derby location should be changed to absolute in the teamserver.properties before deployment.

As you already know, it appears that repotools is constructing the Derby absolute path using the JAZZ_HOME, which means it's looking in the wrong place. If you change your Derby location to absolute in your teamserver.properties, repotools will be able to find the correct location and export should work as expected.
Francis Kemp selected this answer as the correct answer

Comments
Francis Kemp commented Mar 06 '13, 2:21 p.m. | edited Mar 06 '13, 2:48 p.m.

Thanks everyone - I got this working late last week.  I misses the part in the doc concerning the absolute paths for Websphere.


One other answer



permanent link
Ralph Schoon (56.2k23642) | answered Feb 26 '13, 2:40 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Fran, have you looked into the logs created by repotools-jts?

Comments
Francis Kemp commented Feb 26 '13, 3:46 p.m. | edited Feb 26 '13, 4:55 p.m.


Ralph,

Yes - and everything looks normal - except for the 'Exporting items' lines.  Most every line says:

Exported 0 XXX items in 0ms

For JTS, there are only 2 non-zero exported items: RepositoryRoot (1 item) and ContributorRecord (2 items). CCM and QM look similar.

I went into the conf\jts\derby\repositoryDB\seg0 directory and the files in that directory are all very small - like Jazz was just installed.  I'm no Derby expert, but given that we've installed the JKEBanking and have 2 other projects in the database, I'd expect those files to be a lot bigger.

All that being said, Jazz runs fine.  All the data is present in the applications.  It's almost like there is another Derby database on the system holding the data, but the entries in teamserver.properties point to the default location.

Any idea what is going on?

Thanks,

Fran


Francis Kemp commented Feb 26 '13, 4:44 p.m.

Ralph,

I found the Derby databases that are being used. For some reason, the derby databases were created in <WebsphereHome>\AppServer\derby.

For example, the JTS database is stored in <WebsphereHome>\AppServer\derby\conf\jts\derby\repositoryDB.

Any idea why it was stored here as opposed to the normal location under JazzTeamServer?  Guess I'll use absolute paths from now on in teamserver.properties. :)

What's the best way to get repotool-jts to export the data from the new location?  There's no parameter to select a different location for the database. If I run repotools-jts from the <WebsphereHome>\AppServer\derby directory, will it grab the correct data?  Or should i just copy the Derby database to the default location and run repotool-jts normally?

Your answer


Register or to post your answer.