It's all about the answers!

Ask a question

Unable to activate free licenses


Nicolas Echavarria (34813) | asked Feb 20 '13, 12:04 a.m.
retagged Feb 20 '13, 3:35 a.m. by Rajat Singh (59833543)
 Hello guys!

We were on a trial for RTC and our trial licenses expired.
Now, we are trying to use the free developer licenses, but somehow... we can't.

Here, the 10 free licenses are theoretically loaded up on the server:
Installed free licenses

Now, we try to go to a user and select the "Developer" license and the checkbox is grayed out...
Only the "expired" developer licenses show up on the list.
The new "free" licenses are nowhere to be seen in the user license management page.

List of available licenses on user profile

Your help is greatly appreciated,
Best,

Nicolas E.



Comments
Ralph Schoon commented Feb 20 '13, 2:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Nicolas,

I have never seen that, so I can only guess. Can you check, if you have assigned more than 10 developers a license? 


Nicolas Echavarria commented Feb 20 '13, 7:04 p.m.

Ralph,

No, our team comprised of 6 developers.
In fact, I've removed the licenses from everyone.
Please let me know if you have any ideas on how to fix this, as we took lots of pain installing and moving forward with it....

Thanks so much!
Best,

Nicolas E.

Accepted answer


permanent link
Kenery Wang (6411525) | answered Mar 19 '13, 9:20 p.m.
 Hi Nicolas,

Please take a look at this defect item.
https://jazz.net/jazz/web/projects/Jazz%20Collaborative%20ALM#action=com.ibm.team.workitem.viewWorkItem&id=242921
Now I can activate 10 free license normally after I refreshed the jar file of developer trial license in the attachment of work item 242921.
Try it now!! :)

Kenery
Nicolas Echavarria selected this answer as the correct answer

Comments
Nicolas Echavarria commented Mar 19 '13, 11:21 p.m.

Right on Kenery!!

Just refreshed the JAR with the one on the case, and we're good to go!!!!

Thanks so much for sharing!!
Best,

Nicolas E. 

5 other answers



permanent link
Rajat Singh (59833543) | answered Feb 20 '13, 1:01 a.m.
 Hi Nicolas

What is the version of RTC in use?
If v4.0.1, have you uploaded the below license:

On the License Key Management page, you should see an Add option in the section entitled Client License Access Types.  Browse to the zip file, and Finish and that should import the free licenses. 

Best Regards
Rajat

Comments
Nicolas Echavarria commented Feb 20 '13, 8:15 p.m.

Rajat,

Thanks a lot for your response.
However, that was the license we installed, anyway... we removed the one showing in the image and reinstalled from a fresh "RTC-Developer-10-C-License-4.0.1.zip" but... same issue.

I'm not able to assign the licenses to anyone, even though the license shows up on the list of license key management:


The odd thing here is that when we upload the .ZIP here's the info we see:



Shouldn't this license be OK, why is it showing it's expired...
We've downloaded it from:
https://jazz.net/downloads/rational-team-concert/releases/4.0.1?p=gettingStarted

Please help!

Thanks so much!

Nicolas E.


Ralph Schoon commented Feb 21 '13, 2:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Nicolas, I would suggest to open a work item here: https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWelcome

It sure looks odd. If you where on 4.0 I would suggest to upload a 4.0.0.1 or another 4.x license key. It is sure worth a try anyway.


Anthony Kesterton commented Feb 21 '13, 4:46 a.m.
JAZZ DEVELOPER

Not seen this problem either - but agree with Ralph you should grab the free license files from the 4.0.1 download (I am sure you did that - but just wanted to double-check). 

Also - the dialog box says that the server will contact jazz.net to activate the free licenses.  Can your server seen jazz.net?

anthony


Nicolas Echavarria commented Mar 18 '13, 10:21 p.m.

Anthony,


Yes, the server has internet connectivity.
Still unable to either uninstall the old trial license or make work the free one....

Thanks so much for any light you can shed on this issue...
Best,

Nicolas E.


permanent link
Kenery Wang (6411525) | answered Mar 18 '13, 9:53 p.m.
Hi everyone,

I've met this problem as Nicolas too.
I want to run the RTC 4.0 with developer permission.

All the 10-free licenses after the released version 4.0 I've tried but it still don't work.

10-free license will be uploaded and activated but just cannot be assigned to an user!
It will show some messages like "version conflicted"!
How can I solve this problem?

Thanks for reply!

Best Regards 
Kenery

permanent link
Nicolas Echavarria (34813) | answered Mar 18 '13, 10:18 p.m.
 Kenery,

Still on the same boat here!
The server has internet access, however it still appears as the two "sets" of developer licenses are conflicting.
  • There is one set installed as trial, that expired January 13, 2013. 
  • There is one set installed of "free".  On this one is where we get this error:
----
Inactive (The license key "Rational Team Concert-10 Free" is not compatible with the license type "Developer". It is possible that the key was migrated from an earlier version and is now incompatible with the current version. To fix the problem you may want to either replace the key with an updated version or remove the key if it is possible.)
----

We've tried to uninstall the original trial license but get the following error:
"Cannot remove the license "com.ibm.team.rtc.developer". The license is included as part of the server."

Any help on this matter will be greatly appreciated.

Post here please if you're able to make it work!

Nicolas E.

permanent link
Ralph Schoon (60.9k33643) | answered Mar 19 '13, 2:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Please open a work item here: https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWelcome to get development look at it. Thanks!

Comments
Kenery Wang commented Mar 19 '13, 3:22 a.m.

Hi Ralph,


Thanks for the quickly reply,
I've created a defect work item which id is 256530. 
Hope to get the answer as soon as possible.
BTW, I've read your blog about how to write customized plug-ins in RTC.
It's really great helpful for me. :D

Kenery



permanent link
Jean-Pierre Ranger (1) | answered Jul 15 '13, 1:56 p.m.

Hi all,

I thought this was fixed as of CLM 4.0.1. I've just installed 4.0.2 from scratch and have the same problem. I can see the 10 free RTC licenses in the License key utility as 'active'. But I can't assign any to users because only the trial licences show up in the user edit menu. As far as number of users go, the only ones on the server right now are two 'Jazzadmins' users.

I also looked for the work item above 256530 and couldn't find it.

Any thoughts?

Thanks in advance


Comments
Karl Weinert commented Jul 15 '13, 2:56 p.m.
JAZZ DEVELOPER

The defect with the updated licenses is on Work Item 242921 (see the link in the accepted answer)


Jean-Pierre Ranger commented Jul 16 '13, 9:10 a.m.

Thanks Karl.

Cheers,

JP

Your answer


Register or to post your answer.