It's all about the answers!

Ask a question

Move a lot of workitems


Georg Kellner (840479109) | asked Feb 01 '13, 6:10 a.m.
We have a server with different project areas.
The server is running with RTC 3.0.0

In the Eclipse client I can copy/move the elements only one by one.
With nearly thousand workitems a nice job for a rainy day. ;-)

Is there an easy way to copy/move all the workitems with one step?

We are planning to upgrade the RTC to 4.0.1 in the near future.
So the move can also be done with a newer version if there is the needed functionality.

greetings georg.

One answer



permanent link
Lauren Hayward Schaefer (3.3k11727) | answered Feb 01 '13, 6:56 a.m.
JAZZ DEVELOPER
Hi Georg,
Are you trying to move work items between project areas?  If so, I found https://jazz.net/wiki/bin/view/Main/BulkMoveWorkItemsBetweenProjectAreasInRTC3 and https://jazz.net/wiki/bin/view/Main/BulkMoveWorkItemsBetweenProjectAreasInRTC4.

Comments
Gabriel Ben-harosh Hasson commented Mar 11 '13, 7:13 a.m.

Hi Lauren,


The plugin for 4.X doesn't work with 4.0.1. are there any plan to update the plugin soon?

Thanks in advance,
Gabriel. 


1
Ralph Schoon commented Mar 11 '13, 7:19 a.m. | edited Mar 11 '13, 7:20 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi Gabriel, as the wiki entries mentions you should install a compatible version of the eclipse client on your machine, where you deploy the plugin. You can use a 4.0 client and run a against a 4.0.1 server. 

Try to avoid installing into your production RTC client, have one aside that you can throw away. I would test against a test system first.


Gabriel Ben-harosh Hasson commented Mar 11 '13, 10:10 a.m.

Hi Ralph,


Thank you for your quick response.

I tested the plugin on 4.0.0.1 server with 4.0 client and it worked.

After the upgrade to 4.0.1 I installed a clean 4.0 client and tried again, this time it's not working, the Move/Copy option is not available when selecting a bulk to work Items.

Thanks,
Gabriel.


Ralph Schoon commented Mar 11 '13, 10:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Just to make it clear, you installed a fresh vanilla 4.0 client and then you installed the plugin into it and it does not work - after the same process worked before?

To me that indicates that something went wrong when installing the plugin in your new 4.0 client.

I have tried it in the past on a client that I installed using unzip and it worked nicely. If you use a client installed with Install Manager, it could be that the two plugins you have to replace are in different folders. Make sure you really replace the plugins. If you just copy them in and keep the old ones, it will not work.    


Gabriel Ben-harosh Hasson commented Mar 11 '13, 10:46 a.m.

Hi Ralph,


Thank you, it's working now. I think the problem was that instead of replacing the old jars, I renamed them and copied the new ones.

Thanks again.
Gabriel. 


1
Ralph Schoon commented Mar 11 '13, 11:02 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Gabriel, great that it is working now.

Please note sometimes in cases like that you might also want to start the eclipse.exe with the -clean flag. The flag enforces rereading all the installed plug in's again. RTC caches some information and sometimes gets confused if you just replace plugins.

showing 5 of 6 show 1 more comments

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.