r16 - 2015-05-27 - 17:05:52 - StephanieBagotYou are here: TWiki >  Deployment Web > DeploymentTroubleshooting > UpgradeTroubleshooting > CLMUpgradeTroubleshooting > Licenses

Licenses

Authors: UpgradeTroubleshootingTeam
Build basis: CLM 3.x and later

This page discusses common issues seen with licenses when upgrading CLM applications.

License compatibility

All licenses are hosted by the Jazz Team Server in a CLM deployment unless you are using token licenses with the Rational License Server. Jazz Team Server version 4.x can host both 3.x and 4.x licenses including floating, token and authorized users single install. Therefore, if you decide to do an incremental upgrade, the JTS Application must be upgraded first. Similarly, version 4.x licenses can only be installed on a version 4.x Jazz Team Server.

Some important notes:

  • Version 3.0.x applications will continue to function with version 4.x licenses
  • If you are upgrading from version 3.0.1.x, you must obtain 4.0 licenses.
  • Version 4.x licenses must be utilized for version 4.x applications
  • Version 4.0.1 applications will work with version 4.0 licenses, but do not work with version 3.x licenses.
  • If you are upgrading from version 4.0.0.x, you are not required to obtain new licenses for 4.0.1.

Upgrade process for licenses

Version 3.0.x licenses (floating, token or authorized user single install) can be upgraded to 4.x by installing its version 4.x license counterpart. Essentially, this means importing the new license JAR or ZIP file which will overwrite the existing 3.x license. Existing user assignments of each version 3.0.x license are maintained after upgrading to its 4.x license counterpart, except in the following situations:
  • If different license types (for example, token licenses) are installed in 4.x, than the license types used in 3.0.x (for example, floating), then user license assignments must be manually updated.
  • Installing a version 4.x term license does not update its 3.0.x license counterpart. Therefore, user license assignment must be manually updated.

Licenses required for Rational Requirements Composer online migration

For information on the licenses required for RRC online migration, see Migrating the requirements management application.

Known issue: License not compatible error

This section discusses the "License not compatible" error that can occur during an upgrade.

Symptom and cause

You are unable to install the Rational Team Concert WorkGroup license after the upgrade. The error "License not compatible" is displayed.

There is a known defect with the Rational Team Concert Developer for Workgroups trial license in 4.0 which is missing a rule. It will cause this type of license to be incompatible with RTC 4.0 or 4.0.0.x. This defect is fixed in 4.0.1 and is tracked by defect work item 242921.

Solution

The solution is to upgrade to 4.0.1 where this defect is fixed.

If you are unable to upgrade to version 4.0.1, the workaround is to perform the following steps:

  1. Install the Developer Trial license attached to defect 242921.
  2. Install the Developer WG license downloaded from Rational License Key Center.

Related topics: Workaround: Data Collector user is not assigned the Data Collector client access license, Workaround: Install 4.0 license to complete the IBM Rational Requirements Composer on-line migration

External links:

Additional contributors: SusanWu

Edit | Attach | Printable | Raw View | Backlinks: Web, All Webs | History: r16 < r15 < r14 < r13 < r12 | More topic actions
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Contributions are governed by our Terms of Use. Please read the following disclaimer.
Ideas, requests, problems regarding the Deployment wiki? Create a new task in the RTC Deployment wiki project