It's all about the answers!

Ask a question

Why won't RTC accept credentials from Linux client when it will from Windows client?

Dennis LaRue (835) | asked Jan 04 '13, 3:58 p.m.
I recently migrated my laptop from Windows to Linux.  The new RTC client (3.0) will connect to two repositories but not a third.  The same credentials are used on all three.  I still have a windows box running the RTC client and it can connect to all three repositories.  Back on the Linux machine, I can connect to the troubled repository's web interface from Firefox using the same URI and credentials.

The user ID is all lower case.  I've tried connecting from the client using the invitation and manually.  The password contains mixed case alphanumerics, no "special" characters.

I recently posted another question question about this problem because I thought the SSL certificate was the problem (URI didn't match the common name) but Wire Shark showed that the connection was established.

Any suggestions?

Millard Ellingsworth commented Jan 07 '13, 8:11 p.m.

Have you checked the server logs? Usually a failed login attempt will get logged -- perhaps there is some sort of exception that gets manifested as a credentials problem, but isn't really. Is there something "different" about the third repo? Are all three on the same server (and what server version)? When you say that it works from the web UI in Firefox, did you try copying the URI from FF into the repo properties dialog (it sounds like you covered this case, but just in case)? 

Dennis LaRue commented Jan 10 '13, 4:39 p.m.

I'm still going through my help desk to try and find someone with access to the server (big company).

The 3 repositories are all on different servers in different geographical areas.

Yes, I copied the URI between RTC and Firefox, both directions.  Works in Firefox, not in RTC.  And this is only from Linux. From a Windows box everything works.

Definitely a weird problem.

One answer

permanent link
Dennis LaRue (835) | answered Jan 14 '13, 11:43 a.m.
Simple answer, a proper error message would have helped greatly.

Upgrading to RTC Client solved the problem.  The server was configured to not allow a 3.0 client.  Why it chose to express that limitation by saying the credentials were invalid is beyond me.

Ralph Schoon commented Jan 14 '13, 11:50 a.m.

Please file a work item to get this addressed.

Dennis LaRue commented Jan 14 '13, 12:14 p.m.

Done.  Thanks for the suggestion.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.