It's all about the answers!

Ask a question

Showing pending changes in eclipse RTC 4.0.5 client crashes RAD 8.5.5 and 9.0.1?


Tim Bartley (2379) | asked Mar 19 '14, 1:58 a.m.
edited Mar 19 '14, 1:59 a.m.
Since upgrading my RTC to 4.0.5 whenever I show pending changes on a stream RAD crashes - as in seg faults.

I've tried this with RAD 8.5.5, 9.0.0 and 9.0.1 on my Ubuntu 12.10 64-bit Intel Linux system.

Anyone else seeing this or similar? How can I begin to trouble shoot? I haven't yet tried rolling back to 4.0.3 (where I upgraded from) but I have tried a complete re-install of RAD and the RTC client. I need 4.0.5 because I want to take advantage of the better automated merging and gap correction. Our server is only 4.0.5 so I can't try 4.0.6.

This is essentially what I see when I run /opt/IBM/SDP/eclipse from the command line:

Unhandled exception
Type=Segmentation error vmState=0x00070000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=00000000 Signal_Code=00000002
Handler1=00002ADF9885C940 Handler2=00002ADF98C0F900 InaccessibleAddress=00002ADFB996B4E1
RDI=00002ADF9C0D93E0 RSI=0000000001000000 RAX=00000000000000AD RBX=00002ADFB996B4E1
RCX=0000000001000000 RDX=00002AE0C809A198 R8=00002AE0C809BD96 R9=00002AE0C804A130
R10=0000000000000008 R11=0000000000000000 R12=00002ADF9C0D93E0 R13=00002ADFB996B024
R14=00002AE0C809A120 R15=00000000000005BB
RIP=00002ADF9AF90994 GS=0000 FS=0000 RSP=00002ADF9860ABA0
EFlags=0000000000210202 CS=0033 RBP=00000000000000E5 ERR=0000000000000007
TRAPNO=000000000000000E OLDMASK=0000000000000000 CR2=00002ADFB996B4E1
xmm0 00000000000004a3 (f: 1187.000000, d: 5.864559e-321)
xmm1 0000000000000060 (f: 96.000000, d: 4.743030e-322)
xmm2 0000000000000016 (f: 22.000000, d: 1.086944e-322)
xmm3 0000000000000001 (f: 1.000000, d: 4.940656e-324)
xmm4 0000000000000001 (f: 1.000000, d: 4.940656e-324)
xmm5 0000000000000001 (f: 1.000000, d: 4.940656e-324)
xmm6 0000000000000001 (f: 1.000000, d: 4.940656e-324)
xmm7 0000000000000130 (f: 304.000000, d: 1.501960e-321)
xmm8 0000000000000060 (f: 96.000000, d: 4.743030e-322)
xmm9 000000000000000b (f: 11.000000, d: 5.434722e-323)
xmm10 3fe5555555555555 (f: 1431655808.000000, d: 6.666667e-01)
xmm11 3f1a36e2eb1c432d (f: 3944497920.000000, d: 1.000000e-04)
xmm12 3ff0000043190000 (f: 1125711872.000000, d: 1.000000e+00)
xmm13 0000000043437fef (f: 1128497152.000000, d: 5.575517e-315)
xmm14 0000000037800000 (f: 931135488.000000, d: 4.600421e-315)
xmm15 0000000000000000 (f: 0.000000, d: 0.000000e+00)
Module=/opt/IBM/SDP/jdk/jre/lib/amd64/compressedrefs/libj9bcv26.so
Module_base_address=00002ADF9AF87000
Target=2_60_20130617_152572 (Linux 3.5.0-47-generic)
CPU=amd64 (8 logical CPUs) (0x1f03bc000 RAM)
----------- Stack Backtrace -----------
(0x00002ADF9AF90994 [libj9bcv26.so+0x9994])
(0x00002ADF9AF8C38F [libj9bcv26.so+0x538f])
java_lang_J9VMInternals_verifyImpl+0x218 (0x00002ADF9B8EF0C0 [libjclse7b_26.so+0x160c0])
---------------------------------------
JVMDUMP039I Processing dump event "gpf", detail "" at 2014/03/19 15:57:02 - please wait.
JVMDUMP032I JVM requested System dump using '/home/tbartley/core.20140319.155702.9733.0001.dmp' in response to an event

Cheers,

Tim

Accepted answer


permanent link
Krzysztof Kaźmierczyk (7.4k34997) | answered Mar 19 '14, 4:06 a.m.
edited May 21 '14, 6:19 a.m.
Hi Tim,
We had another user having the same issue. Please look at thread https://jazz.net/forum/questions/126400/show-view-pending-changes-kills-rtc-404-client and let us know if commenting -Xshareclasses:name=IBMSDP_%u resolves the problem.
Tim Bartley selected this answer as the correct answer

Comments
Tim Bartley commented Mar 19 '14, 8:29 p.m.

Yes! Thank you! That worked - not sure how I didn't find that with my search. 


radek baranowski commented May 21 '14, 6:26 a.m.

Great piece of advice! Worked for me too on RAD 8.5.1 

Your answer


Register or to post your answer.