It's all about the answers!

Ask a question

RRDI Setup server - "Register" fails

Larry McCarthy (2102124) | asked Dec 09 '12, 1:43 p.m.
edited Dec 09 '12, 1:55 p.m.
CEntOS 6.3 (RHEL 6.3 clone) 64-bit
WAS 64-bit
DB2 Express (not C) V9.7 64-bit
CLM (CCM, QM, RM) 64-bit
Single server
Firefox ESR 10.0.11. Pop-up enabled for localhost and CLMRRDI (this node)

Start the RRDI setup server (as root). Check:
Dec 9, 2012 9:02:05 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 29526 ms

OK. Go to the RRDI Setup server at https://localhost:10443/jts. Get an odd-looking "Register" page - notice there's no password confirmation:
Strange Register screen

Trying to add the URL and RRDI setup user fails:
Strange register screen fails

Nothing jumps out from the logs (same messages on catalina.log)
# cat /opt/IBM/RRDI/setup/logs/rrdi_setup.log
12/09/2012 09:06:09,797 INFO : /opt/IBM/RRDI/setup/tool/JazzTeamServer/server/conf/rrdi
12/09/2012 09:06:11,823 ERROR : java.lang.IllegalStateException: BootstrapConfig.ErrorNotInitialized
12/09/2012 09:08:44,537 INFO : CRRRA0171I: status:200
12/09/2012 09:08:44,537 INFO : CRRRA0172I: response:<!DOCTYPE html>

I double-checked bit-ness. IM Installed Products says:

Shared Resources Directory: /opt/IBM/IMShared
Installation Directory: /opt/IBM/RRDI
Eclipse IDE: /opt/IBM/RRDI
Translations: English
Architecture: 64-bit

/opt/IBM/WebSphere/AppServer/bin/ says:

Architecture          x86-64 (64 bit)
Installed Features    IBM 64-bit SDK for Java, Version 6
                      EJBDeploy tool for pre-EJB 3.0 modules
                      Embeddable EJB container
                      Sample applications
                      Stand-alone thin clients and resource adapters

What might I have done wrong this time?


Edit: images are URL only, no files allowed.

Larry McCarthy commented Dec 09 '12, 2:13 p.m.

Also, same result with Google Chrome.

Accepted answer

permanent link
Benjamin Silverman (4.1k610) | answered Dec 09 '12, 7:05 p.m.
Hi Larry,

The reason there is no password confirmation is because this user/password must be created before you enter it on the rrdi/setup page you've shown above.  To do this, run the in the <RRDI Install>/setup/tool/JazzTeamServer/server folder.  During this process you will create the username/password for the setup admin user and you should be able to proceed with the setup.  Hope it helps,
Larry McCarthy selected this answer as the correct answer

Larry McCarthy commented Dec 10 '12, 12:16 p.m.

Aha! Thanks Benjamin. I was using the 4.0.1 Install Guide for Derp.

Michael Prentice commented Jan 15 '13, 6:54 p.m.

Does this answer apply to 4.0.1? Because I do not have a server.config file in  ibm\RRDI\setup\tool\JazzTeamServer\server. There is a server.startup and file, but no config file. 

One other answer

permanent link
Benjamin Silverman (4.1k610) | answered Jan 15 '13, 7:29 p.m.
Hi Michael,

There is no config file for 4.0.1.  Just start the setup server and proceed with the rrdi/setup wizard (on port 10443 by default).

Michael Prentice commented Jan 15 '13, 8:30 p.m.

Ah OK. The username and password that I gave it would never work. Only after watching some videos and digging through did I find out that I need to use setupadmin/setupadmin to login. This information was not available in the infocenter guide that I was sent to from the Installation Manager ( It looks like it either links to an old guide (4.0) or the guide hasn't been updated for 4.0.1.

I was also confused by the specification of 10443/jts instead of 9443/jts.

Thank you.

James Paulus commented Jan 30 '13, 12:34 p.m.

So, you just used setupadmin for the username and password and it worked?    We are seeing the same issue.    Except we have installed on a different server.    Our port number is 10443, should it be 9443 in this case?

Your answer

Register or to post your answer.