It's all about the answers!

Ask a question

Empty components does not load in Visual studio - RTC 4.0


Karthik Krishnan (8594100149) | asked Dec 05 '12, 9:34 a.m.
Environment: 
  • Visual studio 2010 with RTC 4.0 plugin
  • RTC 4.0
 When we try to load a stream, the empty components are not loaded (with empty folders)

Anyone has experienced this ?

Accepted answer


permanent link
Sreerupa Sen (1.0k4) | answered Dec 06 '12, 1:06 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hi,
    Are you trying to load the components as top level folders? I tried this out and I see that even if you have selected to load the components as top level folders, those component folders are not being created for empty components. If that is indeed your use case., please open a bug on jazz.net.
Cheers
--Rupa
Karthik Krishnan selected this answer as the correct answer

Comments
Karthik Krishnan commented Dec 07 '12, 1:44 a.m.

One other answer



permanent link
Tim Mok (6.6k38) | answered Dec 05 '12, 11:45 a.m.
JAZZ DEVELOPER
If there's nothing to load, what is the reason for loading components with empty folders? If you want to add files to source control, you can share a project into the component without loading it first.

Comments
Rogério Ramos da Silva commented Jan 03 '13, 9:01 a.m. | edited Jan 03 '13, 9:03 a.m.

Isn't true which new files on source control are from a project to be shared. I've faced lots of customers using the SCM to store documents, manuals, etc. In this case a empty component could host files handled outside Visual Studio. 'Cause this the new integration with Windows Explorer has been so expected. In other cases the guy who creates the components may not be one who uses it.


Tim Mok commented Jan 03 '13, 9:49 a.m.
JAZZ DEVELOPER

My team has created Eclipse projects to store documents and such for ease of sharing and loading. Windows Shell integration is also a good solution for this but you'll have two clients to manage your RTC shares.

Creating a VS project might be useful but I'm not sure how that will affect your development environment. It doesn't create any problems in the Eclipse case.

Your answer


Register or to post your answer.