It's all about the answers!

Ask a question

JTS Langage management

Gilles Kekenbosch (16177) | asked Nov 30 '12, 11:56 a.m.

We are currently running JTS with English and French installed languages under windows server 2008 (french).  Users' browsers may use either French or English settings.

As a result,
- some projects are initialized with French, others with English
- some dashboard widgets are displaying english in the container part and french in the content part
- notification mails are using french whatever the case

We are requested to prevent any french data addition, french display or notification mails in french. What should be do... at no risk  ?

1) use installation manager and remove french ? ... does it work ? what about the existing french ?
2) change windows 2008 server french to english ? ... any risk ?
3) is there a mean to prevent users from accessing Jazz with a browser with french settings ?

Many thanks

3 answers

permanent link
Benjamin Silverman (4.1k610) | answered Nov 30 '12, 12:43 p.m.
Hi Giles,

To your questions...

1)  Removing the French language from Installation Manager will remove the translation files from the server, and all clients would see the English strings throughout the application.  You may need to perform a reset of the Jazz Team Server before you can see the changes, as this is the case when you've added a language through IM after already deploying the server.  To do the reset:  https://<JTS-Server>:<port>/jts/admin/cmd/requestReset

2)  Changing the locale on the server itself will only control the translations in the application log files (ie - if server locale is french, the error logs should be in French).

3)  As for preventing users from access the application with French settings, it's not possible at the application level.  Depending on the browser you're using, you can lock down the users ability to change the language (I believe IE can be done via group policy, and FireFox may require additional utilities).

Hope it helps,

permanent link
Simon Washbrook (67216) | answered Feb 13 '14, 2:56 a.m.
Hi Gilles,
If you are using the RTC Eclipse client then you can force it to use English as the interface language, see this discussion:

As Ben said for the browser you have to change the language order that the browser requests. For Firefox this is done via the Tools > Options menu:

IE has a similar option in the General tab then Languages button.

permanent link
Gilles Kekenbosch (16177) | answered Dec 05 '12, 11:19 a.m.
Hello Benjamin,

Thanks for your message. I have just run Installation Manager to remove the french package from the Jazz installation, then I have requested jazz to reset as stated. This was successful... Jazz is still working. (Yes !).

Still, new notification messages are in french. I suspect them to be in french because the OS is french ?.


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.