It's all about the answers!

Ask a question

Corrupting current RTC installation


Alwin Brands (3546) | asked Nov 21 '12, 9:30 a.m.
This is the second time my installation of RTC 3.0.4 gets corrupted. That is it starts showing the startup window and then half way the window disappears. Nothing happens. It stops somewhere at: "...rcp.ui"
This last corruption must have been caused by a CLM 4.0 installation AND not paying too less attention to install it in a different environment (path).

I have de-installed CLM 4.0 and RTC 4.0 Eclipse client. Now RTC works on other workspaces, but not for my original workspace. Is the contents in the .\metadata folder corrupted?

How can I get access again to my original Workspace environment?

(What works is to delete the Metadata and apparently it is re-created. But I hate this trial-and-error.)

Accepted answer


permanent link
Ralph Schoon (55.4k23642) | answered Nov 22 '12, 3:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Alwin, I ran RTC 2.x-RTC4.x Clients on my machine with no issues at all.
I however typically use the zip install for my clients. And my experience with 4.x is that you can not use the same workspace with 3.x and 4.x. You could copy a 3.x workspace and then use it with 4.x, but trying to use one that was used with 4.x did not work for me. I think it is also not a typical scenario. You can use a 3.x client against a 4.x server however, until you have the opportunity to upgrade the Eclipse client.
Alwin Brands selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (55.4k23642) | answered Nov 21 '12, 10:35 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi, I destroyed my workspace for RTC 3.x when using it with RTC 4.x too. It worked with 4.x, but RTC 3.x did not even start when I used that workspace after using RTC 4.x with it. The only way to fix it was to create a new one, or deleting the metadata, I think.

Comments
Alwin Brands commented Nov 22 '12, 3:15 a.m. | edited Nov 22 '12, 3:16 a.m.

Hi Ralph, thanks for your quick response. Can you confirm that it is possible to operate RTC 3.x and RTC 4.0 next to each other? I had both clients working, till I was too careless when installing the whole CLM 4.0 package.

Your answer


Register or to post your answer.