Ram exception: prefix string too short asset upload
2 answers
This is a known problem. Fixed in 7.5.1.2 (in development) with Defect 75146.
The workaround for now is to delete the asset and recreate with no file names that are shorter than three characters. Or leave the file with the name of less than three characters alone. Don't replace it or delete it.
This is because the error occurs when trying to archive the "previous" version of the artifact before deleting or replacing it.
The workaround for now is to delete the asset and recreate with no file names that are shorter than three characters. Or leave the file with the name of less than three characters alone. Don't replace it or delete it.
This is because the error occurs when trying to archive the "previous" version of the artifact before deleting or replacing it.
Richard, Thanks for replying.
But strange thing is that there is no problem with asset file as such. We uploaded the same asset in a different environment without facing any issue. I think this error also occurs in other situations than file name alone.
Also, to give you more information,we started facing this issue after we had problems with disk space. We have increased the disk space, then restarted the server. from then on we are facing this issue. We did Rebuild the index yesterday, and this error was not appearing. But now we see that are lot of corrupted assets, with missing artifacts. (Probably due to errors when disk space was not enough). But this is not expected, I suppose. It is more convenient if the assets are not created at all, when there are issues, instead of creating corrupted assets.
For us to continue further, what is the best way to get rid of these corrupted assets ? We are thinking about clean-up the complete DB, as we are at very early stage of our migration.
Also, to give you more information,we started facing this issue after we had problems with disk space. We have increased the disk space, then restarted the server. from then on we are facing this issue. We did Rebuild the index yesterday, and this error was not appearing. But now we see that are lot of corrupted assets, with missing artifacts. (Probably due to errors when disk space was not enough). But this is not expected, I suppose. It is more convenient if the assets are not created at all, when there are issues, instead of creating corrupted assets.
For us to continue further, what is the best way to get rid of these corrupted assets ? We are thinking about clean-up the complete DB, as we are at very early stage of our migration.
Thanks in Advance,
Venu
Venu