It's all about the answers!

Ask a question

CRJAZ1093I The following service class was not activated: "com.ibm.team.repository.service.internal.schemagen.PersistentMappingService"


Igor Lemes (111812) | asked Sep 28 '12, 1:30 p.m.
 Hi there,
I'm installing JTS and CCM version 3.0.1.3 on a linux machine (RHEL 5). Both applications will run on WebSphere 7.0.0.23 and SQL Server 2008 R2. JAVA version is 6, the one that comes bundled with WAS7.

When i try to run repotools-jts and repotools-ccm I get the following error:
CRJAZ1363I Loading the configuration from "file:conf/jts/teamserver.properties".
CRJAZ1779I This server is configured as a JTS.
CRJAZ1781W The Public URI Root has not been set.  Use the server setup wizard to enter the public URI.  This property is required to enforce consistent URL management in the application.  The public URI represents the URL that all clients must use to access the application.
CRJAZ1365I The server is attempting to connect to the following database: "//sqlpralm:1433;databaseName=jts;user=xxxxxxxx;password=xxxxxxxx;"
CRJAZ1840W The driver "com.microsoft.sqlserver.jdbc.SQLServerDriver" could not be loaded and registered.  This JDBC driver jar must be provided in a path configured by the server scripts.  Please ensure that the driver is in the expected location of "/opt/IBM/JazzTeamServer/server/sqlserver" or consult product setup instructions to change the location.
CRJAZ1093I The following service class was not activated: "com.ibm.team.repository.service.internal.schemagen.PersistentMappingService"
CRJAZ1840W The driver "com.microsoft.sqlserver.jdbc.SQLServerDriver" could not be loaded and registered.  This JDBC driver jar must be provided in a path configured by the server scripts.  Please ensure that the driver is in the expected location of "/opt/IBM/JazzTeamServer/server/sqlserver" or consult product setup instructions to change the location.
CRJAZ1840W The driver "com.microsoft.sqlserver.jdbc.SQLServerDriver" could not be loaded and registered.  This JDBC driver jar must be provided in a path configured by the server scripts.  Please ensure that the driver is in the expected location of "/opt/IBM/JazzTeamServer/server/sqlserver" or consult product setup instructions to change the location.
Creating the tables for the database "//sqlpralm:1433;databaseName=jts;user=xxxxxxxx;password=xxxxxxxx;" with indices.
CRJAZ1141I Cannot get the service "com.ibm.team.repository.service.internal.rdb.IDatabaseCreationService".
CRJAZ1309I The database connectivity service is not ready.
The database tables were not created.

I already googled some of the errors and haven't found anything on this.
Already have modified the teamserver.properties files, added the SQL Server JDBC 4.0 sqljdbc4.jar on the specified address above, aswell as on a different path which i have set on a WebSphere server variable with the same name as in the configuration.

What am i missing here? any reference on the project documentarion?

Sorry if this is a dumb question...
Thanks in advance!


Comments
Clement Liu commented Sep 28 '12, 1:40 p.m. | edited Sep 28 '12, 1:42 p.m.

Were you running repotools-jts.sh -createTables? 


I see this in your log:

CRJAZ1781W The Public URI Root has not been set.  Use the server setup wizard to enter the public URI.  This property is required to enforce consistent URL management in the application.  The public URI represents the URL that all clients must use to access the application.

Run the https://hostname:port/jts/setup first and from there, you can actually create your databases. 

6 answers



permanent link
Igor Lemes (111812) | answered Sep 28 '12, 2:19 p.m.
 yup, actually i was running the script as the following:
repotools-jts.sh -createTables -clean

I tried to do this, by installing the applications on the WAS console and all.
but when i try to run the setup it is not online :/

Thanks, I'll see if i can make the setup work first. :D

Comments
Clement Liu commented Sep 28 '12, 2:32 p.m. | edited Sep 28 '12, 2:32 p.m.

Yep, you need to run the .../jts/setup. The first step of the setup will  ask you to specify the Public URI Root and the second step will ask you to connect to the existing database or create an new one


Clement Liu commented Sep 28 '12, 2:34 p.m.

And pls follow the Interactive installation guide. It would make your life a lot easier. :))



permanent link
Igor Lemes (111812) | answered Sep 28 '12, 3:10 p.m.
 Thanks again, Clement!!
I was able to open the setup page, however, on the first step, to configure the public URI, the box does not appear. Sorry to keep bothering ya, but any idea on why this is happening? Is this common?

Thanks for the 18th time! :)

Comments
Clement Liu commented Sep 28 '12, 7:07 p.m. | edited Sep 28 '12, 7:08 p.m.

Check the JAZZ_HOME value... the step 10 on the following link:


Make sure the path is correct on your Linux box. You can copy the value on your WAS setting and "ls" it on your linux box to make sure it's correct. For example:
>ls /webdata/clm301/JazzTeamServer/server/conf

Last time we had the same issue and we found out there was a space in the value and WAS couldn't find and load the teamserver.properties file.

If the value is indeed correct, can you copy and paste the entries in your ccm.log (or jazz.log) here? 


permanent link
Igor Lemes (111812) | answered Oct 01 '12, 10:58 a.m.
 Hi there!

I've tried renaming the JAZZ_HOME property, but it did not work.
Also, I've tried some of the suggestions on this thread:

The jazz.log was not found neither in the WebSphere dir nor the JazzTeamServer dir, on the path specified by the log4j.properties file.
However, i was able to find log informations on the SystemOut.log file on the WebSphere install dir, and it doesn't give any significant info, stopping after throwing the log info about the LDAP server. (sorry bout the lack of prints)

Any chance this is an firewall error?
I have no clue what is going on... :/

Comments
Clement Liu commented Oct 01 '12, 12:18 p.m.

If you couldn't find either ccm.log or jazz.log on your server, it would be possible that the RTC war file wasn't correctly loaded in WAS. 


We installed our WAS v6.1 to this directory:
/u01/was61

The ccm.log or jazz.log is located in:
/u01/was61/profiles/appsrv/logs/rtc/logs

Replace the "rtc" in the string to your WAS server name.

Can you double check that on your server?


permanent link
Igor Lemes (111812) | answered Oct 01 '12, 11:00 a.m.
My WAS7 is with the fixpack 23, maybe i'm using an bad WebSphere fixpack? 


Comments
Clement Liu commented Oct 01 '12, 12:18 p.m.

According to the Sys Reqs, 7.0.0.23 is fine



permanent link
Igor Lemes (111812) | answered Oct 01 '12, 12:34 p.m.
Yup, checked it and still no luck.
I can't upload the screenshot cause I don't have enough reputation to do it. =/
I'll try reinstalling the application on WebSphere and see if it works.

Thanks!


Comments
Clement Liu commented Oct 01 '12, 1:35 p.m. | edited Oct 01 '12, 1:35 p.m.
Did you follow the steps on this link to deploy the applications to WAS? 

If that still wouldn't solve the problem, I'd suggest you open a PMR to IBM support and have them review your environment (You can ask them to set up an online screen sharing session with you)

Good luck... 


permanent link
Igor Lemes (111812) | answered Oct 01 '12, 1:40 p.m.
Yeah, i have followed these steps.
I have opened the PMR to IBM support, and they're working on it with us.
When we get a solution, i'll sure come back and post it here.

Thanks a lot for your time!


Your answer


Register or to post your answer.