It's all about the answers!

Ask a question

Jazzmon Monitor is not working


Srikanth Bhushan (16942734) | asked Aug 08 '12, 3:36 a.m.

Hi,

Tried using JazzMon monitor without much success yet. This is what I tried

  1. Copied jmTemplate.properties to jm.properties
  2. Added the right values for SERVER_URL_LIST, SEQ_RUN_LENGTH_ARG=2, SEQ_USERNAME and SEQ_Properties in the jm.properties
  3. Run the command :

java -jar JazzMon.jar monitor
Output directory exists already (c:\temp\JazzMonRuntime)
Do you want to delete existing directory ?(y/n):
y
<localHost name="XXXXX"
description="(auto-generated)"
architecture="x86"
os="Windows XP"
osVersion="5.1"
bundleVersion="3.0_GA"
/>

Properties loaded from XXXX\JazzMon\JazzMon_1.2.1_RTC30GA\JazzMon_1.2.1_R
TC30GA\.\jm.properties

EXCEPTION: Invalid char to decode: 64

Am I missing anything? The Java version is 1.7

Accepted answer


permanent link
sam detweiler (12.5k6186201) | answered Aug 08 '12, 7:17 a.m.
another user has reported that when the user password contains a special character (!) the startup fails.
the password I am using has '#'  and works ok

other than that I am on Windows 7, 64bit, still java 6, we did the same thing
Srikanth Bhushan selected this answer as the correct answer

6 other answers



permanent link
Dave Schlegel (331157) | answered Sep 16 '13, 12:00 p.m.
JAZZ DEVELOPER
Hi Matthew - Could you provide an example password comparable to the one that is failing, i.e. same length and use of special chars, etc. I'll see what happens when its encoded and decoded. Thanks.


Comments
Matthew Owenby commented Sep 16 '13, 12:49 p.m.

A123BcdeF123Ghij#


Karthik Krishnan commented Sep 19 '13, 7:11 a.m.

Also with § character in Windows 7 


permanent link
Srikanth Bhushan (16942734) | answered Aug 08 '12, 7:21 a.m.
I guess thats the problem. Mine contains an "@" .

permanent link
Dave Schlegel (331157) | answered Aug 21 '12, 5:18 p.m.
JAZZ DEVELOPER
We've provided a fix for this password defect in JazzMon 1.2.2 which I've just posted to the JazzMon wiki area. If this is still a problem please try the latest release.

permanent link
Matthew Owenby (23711) | answered Aug 13 '13, 2:40 p.m.
Doesn't work with long passwords!

permanent link
Matthew Owenby (23711) | answered Aug 13 '13, 2:40 p.m.
with version 1.4

permanent link
Dave Schlegel (331157) | answered Sep 18 '13, 6:24 p.m.
JAZZ DEVELOPER
Filed JazzMon password encoding doesn't work with long passwords (281180) to try to address in the upcoming release.

Your answer


Register or to post your answer.