It's all about the answers!

Ask a question

Test Connection Exception Error


Justin Holst (2143) | asked Aug 07 '12, 8:14 p.m.
I am trying to add a new Build Forge agent machine to my server.  The server and the agent are geographically very far apart (San Jose, CA -> Madrid).  I can remote to the Madrid machine fine as I have been configuring it to use for our processes.  When I went to add the server to the Build Forge server list I get the following error when testing the connection.

My agent version is listed below.  The server is 7.1.2.2-1-01111.  The agent version is the same for all of my agent machines (over 100).

This exception isn't giving me much to work with here.  Has anyone seen this before?

Host: XXXXXXXXXXXXXXXXXXXXXXXXXXXX
Agent Version: 7.1.2.2-1-0100
Authentication: XXXXXXXXXXX
Platform: Windows 7
Status: Functional failure
Duration: 31
			
		200 HELLO - BuildForge Agent v7.1.2.2-1-0100
320 AUTH AuthRunningAs["SYSTEM","NT AUTHORITY",*WinSidUser]
320 AUTH AuthPriv["Replace a process level token"]
320 AUTH AuthPriv["Lock pages in memory"]
320 AUTH AuthPriv["Adjust memory quotas for a process"]
320 AUTH AuthPriv["Act as part of the operating system"]
320 AUTH AuthPriv["Manage auditing and security log"]
320 AUTH AuthPriv["Take ownership of files or other objects"]
320 AUTH AuthPriv["Load and unload device drivers"]
320 AUTH AuthPriv["Profile system performance"]
320 AUTH AuthPriv["Change the system time"]
320 AUTH AuthPriv["Profile single process"]
320 AUTH AuthPriv["Increase scheduling priority"]
320 AUTH AuthPriv["Create a pagefile"]
320 AUTH AuthPriv["Create permanent shared objects"]
320 AUTH AuthPriv["Back up files and directories"]
320 AUTH AuthPriv["Restore files and directories"]
320 AUTH AuthPriv["Shut down the system"]
320 AUTH AuthPriv["Debug programs"]
320 AUTH AuthPriv["Generate security audits"]
320 AUTH AuthPriv["Modify firmware environment values"]
320 AUTH AuthPriv["Bypass traverse checking"]
320 AUTH AuthPriv["Remove computer from docking station"]
320 AUTH AuthPriv["Perform volume maintenance tasks"]
320 AUTH AuthPriv["Impersonate a client after authentication"]
320 AUTH AuthPriv["Create global objects"]
320 AUTH AuthPriv["Increase a process working set"]
320 AUTH AuthPriv["Change the time zone"]
320 AUTH AuthPriv["Create symbolic links"]

java.util.concurrent.TimeoutException
	at com.ibm.jas.agent.AgentConnection.checkTimeout(AgentConnection.java:64)
	at com.ibm.jas.agent.AgentConnection.readLine(AgentConnection.java:159)
	at com.ibm.jas.agent.AgentConnection.readMessage(AgentConnection.java:127)
	at com.ibm.jas.agent.AgentConnection.readMessage(AgentConnection.java:120)
	at com.ibm.jas.agent.action.ReadAgentConnection.action(ReadAgentConnection.java:45)
	at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:197)
	at com.ibm.jas.fiber.action.flow.Block.action(Block.java:63)
	at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:197)
	at com.ibm.jas.fiber.action.flow.Block.action(Block.java:63)
	at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:197)
	at com.ibm.jas.agent.AgentFiber.action(AgentFiber.java:234)
	at com.ibm.jas.agent.AgentFiber$AgentFiberAction.action(AgentFiber.java:339)
	at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:197)
	at com.ibm.jas.fiber.Fiber.runFiber(Fiber.java:670)
	at com.ibm.jas.fiber.FiberThread.runFibers(FiberThread.java:258)
	at com.ibm.jas.fiber.FiberThread.run(FiberThread.java:246)
	


One answer



permanent link
David Brauneis (50611) | answered Sep 13 '12, 1:20 p.m.
JAZZ DEVELOPER
I would try increasing the value for Server Usage Connect Timeout in the System Configurations since there is likely some latency between the BF Server and the BF Agent.

If that does not work, I might suggest creating a PMR and working through the support process.

Your answer


Register or to post your answer.