It's all about the answers!

Ask a question

About using double-byte characters in scm command line


akiko yamaguchi (6278) | asked Jul 31 '12, 8:58 p.m.
Hi all,
I need to use Japanese in scm command line.
I tried the following two subcommand. One went well, while another didn't.
'scm changeset relocate 1000 <Japanese file or folder name>' worked fine, but 'scm share -r xxx -u xxx repositry_wksc <Japanese folder name>' failed.
(When I used English folder name, it worked fine.)

I'm using RTC v4.0.
Does anybody have any information?
Thanks in advance.

One answer



permanent link
Andrew Niefer (7035) | answered Aug 01 '12, 11:27 a.m.
JAZZ DEVELOPER
There is probably a number of things that could go wrong here, but on windows the scm launcher generally needs to convert  multibyte characters it it receives on the command line into wide unicode characters.

It does this using the function <tt>MultiByteToWideChar</tt> using <tt>CP_ACP</tt>, the system default Windows ANSI code page.  You probably need to set your default code page to something that supports Japanese.

You can try using <tt>chcp</tt> to change the active console code page, perhaps to 932.  Or else change Window's Regional and Language Options to specify Japanese.

Your answer


Register or to post your answer.