It's all about the answers!

Ask a question

How do I create a task board for a specific set of work items?


0
1
Evan Hughes (2.4k1018) | asked Jul 31 '12, 4:25 p.m.
JAZZ DEVELOPER
I'm trying to create a (web UI) task board that shows a specific set of stories and work items. The WIs all have the same iteration (which is shared with many other work items), but a unique tag, and a unique parent/ancestor hierarchy. They do not share a work item category.

How do I create a task board that only shows those work items? 

I've been experimenting on this view. I only want to see the descendants of WI 218177

I've tried applying filters to the view config but those work with varying degrees of success.

Accepted answer


permanent link
Guido Schneider (3.3k137699) | answered Aug 01 '12, 6:36 a.m.
edited Aug 01 '12, 6:05 p.m.
Try with an expression filter on tags: you can do a NOT in front of the filter.
E.g. "!tags:scm". This filters out all workitems without the SCM tag. You can also use multiple tags in the expression. Just separate the expressions with space.


Evan Hughes selected this answer as the correct answer

Comments
Evan Hughes commented Aug 01 '12, 10:07 a.m.
JAZZ DEVELOPER

The WIs that I want to see are tagged with 'scmrun401candidate'.

If I set the quick filter to be "!tag:scmrun401candidate" all items are removed from the task board. I see the same behaviour if I remove the '!'.

When I set the view's config to '!tag:scmrun401candidate' or 'tag:scmrun401candidate' all work items appear to be shown.

I've raised bug 219840 and bug 219836.


Andrew Codrington commented Aug 01 '12, 11:47 a.m.

Is this as simple as a typo? eg tags vs tag

I'm using 3.0.1.2 and I can get Colors to work on WIs by using tags:mytagname, not tag:mytagname as you've shown above.

The ! operator also works as expected (!tags:mytagname).


Evan Hughes commented Aug 01 '12, 4:16 p.m.
JAZZ DEVELOPER

My mistake! With the full 'tags' keyword it works as expected! Damn! I spent 3 hours trying to get this stuff to work, and all because of a stupid typo.

I'll close those work items.


Guido Schneider commented Aug 01 '12, 6:06 p.m.

Sorry Evan for my typo in my answer. I have corrected it for all followers.

2 other answers



permanent link
Henning Sternkicker (40626) | answered Aug 01 '12, 3:18 a.m.
JAZZ DEVELOPER
Have you tried to use the Display option "Group" instead? You can use the group option on tags, this will result in a taskboard that is devided into groups regarding their tags. That means, if your work items all have the same tags, they will appear in the same group.

Comments
Evan Hughes commented Aug 01 '12, 10:56 a.m.
JAZZ DEVELOPER

This works, although I have to reorder my tags to put the tag I care about at the front of the tag list. I've raised bug 219853 about that.

Thanks!


Guido Schneider commented Aug 01 '12, 6:07 p.m.

As much as I know the Group on tag is based on the "primary tag". This is the first tag in the list. All others are secondary tags.


permanent link
Dinesh Kumar (4.0k413) | answered Jul 31 '12, 4:45 p.m.
JAZZ DEVELOPER
filter is the one which can pull out the specific tagged workitems. 

however in plan views, I understand that the way filter works is the exact opposite of what you are looking for.. applying a filter saying filter : tags:scm will show you all workitems which do not have the tag scm by filtering out the "scm" "tagged" workitems..

so a not so neat way of getting it to work is to apply tags filter on all other tags available for you.  however when a new tag gets added, this view needs modification on its filters.. not very neat as i said earlier..

Your answer


Register or to post your answer.