It's all about the answers!

Ask a question

CRJAZ2015E The value of the parameters "oldJTSHome" and "newJTSHome" must not refer to the same JTS home directories.


mrp singer (1021315) | asked Jul 21 '12, 2:49 a.m.
Hi All

I am trying to upgrade RTC3.0 to RTC 4.0 and getting error on step 0 and can some help me
Back ground:
1. Wanted to use RTC 3.0 process template to RTC4.0 for that i need to upgrade
2. i have RTC 3.0 and running this command
3. Do i need to install RTC4.0 on the same machine and go RTC3.0 install directory and run the "jts_upgrade.bat" and "ccm_upgrade.bat"

Please help me to understand the process
Thanks in advance
mrp

4 answers



permanent link
Ralph Schoon (60.9k33643) | answered Jul 21 '12, 3:58 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jul 21 '12, 3:59 a.m.
 The error is quite descriptive. You have to do a side by side install and the oldJTShome needs to be pointed to the old install folder.

I would also suggest to run the upgrade guide in the help. It is quite good.

Comments
mrp singer commented Jul 21 '12, 5:05 a.m.

Hi Ralph I am bit confused now.. as per upgrade guide asking install CLM4.0 in Step3. It means that i should install RTC 4.0 ? on the same machine and configure then continue step 4 ? Pls lemme know thank you


permanent link
Ralph Schoon (60.9k33643) | answered Jul 21 '12, 11:15 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
If you upgrade an appkication (jsts, ccm,...) from 3.x to 4.0 on the same machine, you install 4.0 on the same machine. Then you follow the steps to get the settings from the teamserver.properties over to the new install etc. Then you deploy/start the new server, and you are done.

Comments
Ralph Schoon commented Jul 22 '12, 5:05 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I should have added, you install in a different folder. You should not and can't install over.


mrp singer commented Jul 22 '12, 5:15 a.m.

Hi Raplh Thank you so much and now i have upgraded successfully. When open RTC4.0 and try to login and gettting error This is from RTC4.0 Client Connetion error ============================= CRJAZ0106I The server is temporarily unavailable, the request the request for the URL " /ccm/service/com.ibm.team.repository.common.internal.IRepositoryRemoteService" was denied. Please retry again later,or if the error persists, contact your administrator once i login/ can import RTC3.0 template

This error from Web client/when i login

CRJAZ1972E The "com.ibm.team.dashboard.service.internal.legacy.LegacyDashboardRestService" service failed to activate because a service that it depends on, "com.ibm.team.repository.common.service.IContributorService", failed to be activated. For more details, open the help system and search for CRJAZ1972E.

Error:com.ibm.team.repository.web.transport.ServiceRequest(): Invalid requestParameters parameter: [object Object]

Can suggest me please Thank you


permanent link
Ralph Schoon (60.9k33643) | answered Jul 23 '12, 2:05 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
This error seems to suggest that a database is not accessible.

Comments
mrp singer commented Jul 24 '12, 1:36 a.m.

Hi Ralph I could not succeeded to use RTC 3.0's process template in RTC 4.0 i followed two ways 1st way 1. installed RTC.30 and RTC 4.0 and configured saperately 2. from RTC4.0 : run the jst update and ccm update 3. it got succesfully , when tried to open RTC4.0 and getting above error but RTC 3.0 setting instact and its working as before 2nd way 1. Re -installed RTC.4 0 and not configured anything 2. from RTC4.0 : run the jst update and ccm update 3. it got succesfully , when tried to open RTC4.0 and getting above error

How to proceed futher, can you assit me ., please


permanent link
Ralph Schoon (60.9k33643) | answered Jul 24 '12, 3:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
My best suggestion is to do the following:

1.1 Export the template on your current environment.
1.2 Install the latest version of RTC that your templates work for. Just install on Tomcat, Derby. JTS and RTC, on one machine.
1.3 Run the setup. Make sure the diagnostics in https://host:port/jts/admin and https://host:port/jts/admin shows no error! If you install on Windows you want to avoid to install into the Program Files folders.
1.4 After a successful setup, Import the template that you exported. Check the template imported and works (create a project area from it)

2.1 Install - side by side - RTC 4.0, just Tomcat and Derby, JTS, CCM, on the same machine. The machine wuould require at least 4GB RAM to run.
2.2 Carefully follow: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html to upgrade.Be aware you have to copy the Derby database(s) over to the right location in JTS and RTC (and if you install all, to the other products).
2.3 Carefully check the upgrade logs
2.4 Check https://host:port/jts/admin#action=com.ibm.team.repository.admin.serverDiagnostics and https://host:port/ccm/admin#action=com.ibm.team.repository.admin.serverDiagnostics and make sure there are no errors. If there are, restart at 2.1. Make sure you have all the correct permissions and the machine has enough resources.
2.5 Check for your template. Create another project area.
2.6 If that works export the template and you can re import it on any production system.

If this does not work, please consider to write a work item or a PMR to get support involved. That would allow to share logs and screenshots. There is just not enough information to work with here in the forum post.

Your answer


Register or to post your answer.