It's all about the answers!

Ask a question

Can not sort by state properly


ryosuke oka (17984548) | asked Jun 19 '12, 4:23 a.m.
It seems to be sorting by state do work for only defect and Task but not for Story or Epic.
If I sort by state, I still see Story or Epic is not in order. These work item types are some how got a priority of TYPE rather than state.

Is this working as design?
If so, how do we know what work item type has this behavior?

Thank you, in advance.

One answer



permanent link
Arne Bister (2.6k12732) | answered Jun 19 '12, 8:02 a.m.
JAZZ DEVELOPER
Hi,

I just verified in RTC 3.0.1 and 4.0 web client that the behavior for queries is as expected if you edit the query to modify the sort order for state. So if you add "state" as a sorting column in the Result Layout --> Sort Order, the query will sort for state regardless of work item type.

But if you click on the "state" column in an already executed query, the sorting will actually take into account work item type. Apparently, plan items, execution items and "the rest" (impediments, retrospectives) are used as groups, within which the states are sorted.

I share your observation that this is different behavior from clicking on e.g. priority column. If it bothers you a lot, please file an Enhancement Request against RTC.

A workaround would be to not use the click on state column for sorting but instead edit the query, add state as a sorting column. Another workaround is to use queries which filter only work items types that are considered as a group for sorting (i.e. task + defect ; story + epic)

Does this answer your question?

- Arne


Comments
ryosuke oka commented Jun 19 '12, 10:14 p.m.

Hi Arne,

Thank you for your answer. I had edit the query and add the state for sorting and execute it but Story and Epic still dose not sort by state.

Do you know how RTC categorize work Item types as a group? If adding a sort work on your machine and not my machine, there must be some settings for the grouping of work item's type.


Arne Bister commented Jun 20 '12, 7:20 a.m.
JAZZ DEVELOPER

Hi, make sure to add the column "state" under Sort Order in tab Column display. Usually there is already a column "modified date". You can either remove that (hover over, click cross on right side) or highlight it and then press the "down" link now visible at the bottom of the Sort Order. On that note, I really would like the ability to easily include screenhots here :-) If it helps, maybe you can use the open jazz.net sandbox to recreate the issue and invite me to your project to look at the query. - Arne

Your answer


Register or to post your answer.