It's all about the answers!

Ask a question

Versionable cannot be committed with a null or empty name

Eric Kolotyluk (12185) | asked Apr 07 '11, 7:26 p.m.
I'm trying to share a project via Eclipse, but when I click finish in the wizard I get an error message with details:
Versionable cannot be committed with a null or empty name.

Does anyone have any idea what is going on?

Cheers, Eric

3 answers

permanent link
Eric Kolotyluk (12185) | answered Apr 18 '11, 3:04 p.m.
Last time I was trying to get this working with M13 so I installed RC1 and I am having the same problem.

I am using the RCT plug-in with Eclipse SDK 3.6.1 as well as the Sonotype Maven plug-in. The projects in my Eclipse workspace were created using the Maven plug-in. There is a top level POM project and four modules as JAR projects.

When I tried to 'share' the project using Jazz I still get the same error as before. This time I had someone who consults on Jazz walk me through it and we still got the same error.

Next we tried creating plain Java project in the workspace and sharing that and got

Then I created a fresh Eclipse workspace and a simple Java project. I was able to share that in RTC without problem.

Finally I went back to my original workspace, and only tried to share the 4 JAR projects and not the top level POM project. This time I got a Java NullPointerException thrown, but it seems it did copy some or all the files from my sandbox to the workspace.

I was able to check in and deliver the 4 JAR projects, but I seem to have no wat to check in and delver the top level POM project.

It seems Jazz does not like dealing with the way my Eclipse Workspace is configured. On the other hand Eclipse has no trouble with it.

Could this be bug in RTC?

Cheers, Eric

permanent link
Michael Valenta (3.7k3) | answered Apr 20 '11, 8:09 a.m.
It certainly looks like there is at least one bug in RTC here. Would it be possible for you to provide the steps you took so we can try and reproduce the failure? It would also be helpful to understand how you ended up with nested sandboxes. This is not supported by RTC and it would be helpful to us to understand how you got in this situation so we could try and prevent it in a more helpful way.

permanent link
Eric Kolotyluk (12185) | answered Apr 20 '11, 11:57 a.m.
The problem was that I used Maven to set up my projects before I tried sharing them with RTC. See for more information on this. Eventually I referred to to figure out how to set up Maven. It was much harder to figure out how to move the Eclipse projects to all be on the same level, but ultimately I was able to get it working.

Cheers, Eric

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.