It's all about the answers!

Ask a question

Data Loss - Remote project viewlets missing


Mark Ingebretson (58514835) | asked Nov 23 '10, 11:38 a.m.
We have a major development RTC project which uses RTC integrations to
seven other repositories. They've got a mission-critical dashboard
which contains about 25 status viewlets from the primary project, as
well as from the other remote projects.

Last Friday night there was a powerdown event, and the machines were
brought down, and later brought back up.

After the powerdown the users noticed that most of the viewlets on this
dashboard are now gone. Only the local viewlets remain, all the remote
viewlets are missing.

It's not very clear when the dashboard was last working, so we're not
sure the problem is tied to the powerdown or not. We did find an NPE in
the server log:

ERROR
m.team.dashboard.service.internal.util.ProcessUtil - Error finding
project area "null"
java.lang.NullPointerException
at java.net.URLEncoder.encode(URLEncoder.java:227)

We would greatly appreciate some assistance in understanding how this
happened, how to prevent it in the future, and help to get the dashboard
back to the state it was in last Friday.

So far we've restarted the primary project, and the dashboard is still
missing the remote viewlets. We tried re-creating one of the remote
viewlets, and that was successful, so the connection (at least one of
them) is still working.

We're beginning to set up a project clone using a backup from last week
to use for re-creating the production dashboard.

If there are any other suggestions we'd be glad to hear them.

One answer



permanent link
Anthony Kesterton (7.5k5177136) | answered Feb 23 '11, 3:56 a.m.
JAZZ DEVELOPER
We have a major development RTC project which uses RTC integrations to
seven other repositories. They've got a mission-critical dashboard
which contains about 25 status viewlets from the primary project, as
well as from the other remote projects.

Last Friday night there was a powerdown event, and the machines were
brought down, and later brought back up.

After the powerdown the users noticed that most of the viewlets on this
dashboard are now gone. Only the local viewlets remain, all the remote
viewlets are missing.

It's not very clear when the dashboard was last working, so we're not
sure the problem is tied to the powerdown or not. We did find an NPE in
the server log:

ERROR
m.team.dashboard.service.internal.util.ProcessUtil - Error finding
project area "null"
java.lang.NullPointerException
at java.net.URLEncoder.encode(URLEncoder.java:227)

We would greatly appreciate some assistance in understanding how this
happened, how to prevent it in the future, and help to get the dashboard
back to the state it was in last Friday.

So far we've restarted the primary project, and the dashboard is still
missing the remote viewlets. We tried re-creating one of the remote
viewlets, and that was successful, so the connection (at least one of
them) is still working.

We're beginning to set up a project clone using a backup from last week
to use for re-creating the production dashboard.

If there are any other suggestions we'd be glad to hear them.


Hi Mark

Please raise a defect on jazz.net, and also raise a support PMR with IBM support. This should not happen (obviously) so while you still have data like logs, etc - this is a good time to investigate this.

thanks

anthony

Your answer


Register or to post your answer.