It's all about the answers!

Ask a question

When I click on "Show in Rhapsody" option in RDNG which is linked with a Model Artefact, It is not able to redirect me to the model element

Sandesh Puranik (112) | asked Apr 05, 1:19 a.m.
edited Apr 10, 2:25 a.m.


We have established the traceability between Model artefacts and Requirements in RDNG, when I hover on the linked artefact which is being displayed in RDNG there pops a option called "Show in Rhapsody", Ideally it should redirect me to that model element, any help is greatly appreciated!  
Version details:
IBM EWM -  7.0.2 iFix015
Rhapsody- 9.0.1 - 64 bit

Thanks & Regards,
MBSE Engineer

Ralph Schoon commented Apr 05, 1:36 a.m.

So what happens if you click the button? 

Sandesh Puranik commented Apr 05, 1:41 a.m.

The RDNG page gives a pop up asking for it to allow and open Rhapsody when I allow, the rhapsody icon in windows bar glows, but when I open Rhapsody nothing happens!, I want it to point at exact model artefact which I chose in DNG 

Davyd Norris commented Apr 05, 2:17 a.m.

Have you tried opening and loading the model first, or are you starting from Rhapsody with no model loaded?

Sandesh Puranik commented Apr 05, 3:18 a.m.

 Tried both the methods but still the same!

Ian Barnard commented Apr 05, 12:50 p.m.

What version ELM and Rhapsody? What iFix? Please edit these into your question and ALWAYS include this info when you create future questions so when others read your questions they might know if the question is relevant to them. If your versions are in support you should create a support case.

Sandesh Puranik commented Apr 10, 2:24 a.m.

I apologize for not mentioning the Versions I use, please find the version details below

IBM EWM -  7.0.2 iFix015
Rhapsody- 9.0.1 - 64 bit

showing 5 of 6 show 1 more comments

One answer

permanent link
David Lafreniere (4.8k7) | answered Apr 26, 3:56 p.m.
edited Apr 26, 3:56 p.m.

 There is a couple requirements for this to work.
-You need to have the Rhapsody client open
-A model project needs to be opened in Rhapsody
-The model element needs to exist in the opened model project in Rhapsody

^ For those that might not know how this action works, that is the 'general' answer.

A few other questions might be required if that's not the case though:

1. Do you have multiple Rhapsody clients open. I never tried this, but I assume if you do have multiple Rhapsody clients, it might not be able to open one and show the model (especially if different clients had the same [or different versions] of the model element.

2. Is your opened model project RMM enabled, and is it currently 'online' and connected to an EWM Eclipse client with the Rhapsody plugin installed? (I'm not positive this is related though).

3. Is the project GC enabled (opt-in)? Ex: On the DNG page, you have a GC context selected at the top right of the web-page. Inside of the Rhapsody client, does it also have the same GC selected and do you have files loaded from SCM that belong to the selected GC? Ex: It's possible to have a different GC loaded/selected in Rhapsody than what you are looking at in the web.

4. If instead of clicking the 'Open in Rhapsody' button from the compact rendering directly in DNG, can you try clicking on the link to navigate to the RMM web-ui. Does the 'Open in Rhapsody' button work there? (to see if there's some issue with the logic when ran from a compact rendering)

5. Has the 'Open in Rhapsody' button ever worked for you? If it suddenly stopped working, has anything change with your configuration? Does it work for any colleges that may have the same setup (client/server version, etc.) (to see if it's some strange issue with your machine).

Your answer

Register or to post your answer.