It's all about the answers!

Ask a question

RQM csv export - wrong format to edit by Excel


Sandro Gross (132) | asked May 03 '22, 9:31 a.m.
Hi there
I export some test cases to a csv file, for a faster copy option and changes of test cases and upload back to RQM.
First - I select the test cases in the TC overview with categories and attributes I need and than I do export to a csv file.
The Problem is - If I have several lines in a attribute (e.g. procedure) than does the csv file a next line.

Well, in this form of the csv file isn't good to editing.
Have anybody an idea?

(we are using RQM version 6.0.6)

*Example from a csv file ( i need this i one line)

"Test_Specification, TestSpec_Testcases","97, 106","TestCase_ABC02","Ihr könnte Dein Text stehen ","unassigned","n.a.","Analysis of requirement","pressure 25%
power 50 kW
50 A","1","2","3","https://webdngprx1vt.global.web-int.net/rm/resources/MB_b4ed3cb967f0435bbe392a0100d4a499?oslc_config.context=https%3A%2F%2Fwebdngprx1vt.global.web-int.net%2Fgc%2Fconfiguration%2F292","378514: battery pack shall not collapse"




Accepted answer


permanent link
Ralph Schoon (61.6k33643) | answered May 04 '22, 1:58 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited May 04 '22, 2:00 a.m.
This is how the CSV files are composed if there are newline characters in exported attributes. This is the way it is, and if it wasn't users would complain about it.

The problem is not so much that the CSV file is formatted that way, it is more that this makes it hard to use Notepad++ or other text editors to understand the column you are looking at.

You can use OpenOffice or Excel to edit those files.

But, Excel is not importing CSV files correctly if you just open Excel on them. Excel likes to import semicolon or blank separated files instead - at least on my machine.

To be able to edit those files, open Excel, select the Data menu select From Text/CSV, select the file, select the delimiter (which is usually already computed from the file), then import the file if it is to your liking. Happy editing.

Open Office  correctly opens CSV files as far as I remember.
Sandro Gross selected this answer as the correct answer

2 other answers



permanent link
David Honey (1.2k17) | answered May 03 '22, 12:25 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

It seems to me the problem is not the format, but the tool you are using for editing. Open the CSV in Excel, make the changes there, then save as a CSV from Excel. CSV files allow column values to contain multiple lines, and such values are quoted. That's what you are seeing. This shouldn't be a problem if you edit the contents in Excel.


permanent link
Sandro Gross (132) | answered May 04 '22, 7:54 a.m.

Hello Ralph & David 

Thanks a lot for your answers.
I know the edit option in excel with delimited but excel cannot correct interpret the csv file :(
I tried this with open office - wow this tool can exactly interpret the csv file. All lines in a Attribute were correct shown.

Unfortunately, install of open office isn't a solution for my colleagues, i must look for another way. 
(maybe with report builder)


Comments
Ralph Schoon commented May 04 '22, 8:00 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

As I said, you can open the data correctly in Excel as far as I can tell.

Your answer


Register or to post your answer.