It's all about the answers!

Ask a question

Compatibility issues between Eclipse 4.22/ 4.23 and EWM 7.0.2

Andrew Tram (11) | asked Mar 26 '22, 8:10 p.m.

 I've seen this following issues when install EWM 702 on top of Eclipse 4.22 and 4.23:

org.osgi.framework.BundleException: Could not resolve module: [748]
  Unresolved requirement: Require-Bundle:
    -> Bundle-SymbolicName:; bundle-version="1.3.8000.v20200825_0118"; singleton:="true" [777]
         No resolution report for the bundle.  Bundle was not resolved because of a uses constraint violation.
  org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource [osgi.identity; osgi.identity=""; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"] because it is exposed to package 'javax.servlet' from resources javax.servlet [osgi.identity; osgi.identity="javax.servlet"; type="osgi.bundle"; version:Version="3.0.0.v201112011016"] and jakarta.servlet-api [osgi.identity; type="osgi.bundle"; version:Version="4.0.0"; osgi.identity="jakarta.servlet-api"] via two dependency chains.

Chain 1: [osgi.identity; osgi.identity=""; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"]
    require: (osgi.wiring.bundle=javax.servlet)
    provide: osgi.wiring.bundle: javax.servlet
  javax.servlet [osgi.identity; osgi.identity="javax.servlet"; type="osgi.bundle"; version:Version="3.0.0.v201112011016"]

Chain 2: [osgi.identity; osgi.identity=""; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"]
    require: (
    provide: osgi.wiring.bundle; bundle-version:Version="1.3.7000.v20200604_0355"; osgi.wiring.bundle=""; singleton:="true"
  org.apache.commons.logging [osgi.identity; type="osgi.bundle"; version:Version="1.2.0.v20180409-1502"; osgi.identity="org.apache.commons.logging"]
    import: (osgi.wiring.package=javax.servlet)
    export: osgi.wiring.package: javax.servlet
  jakarta.servlet-api [osgi.identity; type="osgi.bundle"; version:Version="4.0.0"; osgi.identity="jakarta.servlet-api"]
at org.eclipse.osgi.container.Module.start(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
at org.eclipse.osgi.framework.eventmgr.EventManager$

This issues can be seen after install and going to the Team Artifacts view - some links like connecting to a repository workspace are missing and triggers those wiring errors.

It seems to have worked up to Eclipse 4.21, but something has changed with Eclipse since then to cause it to no longer work. I understand that EWM doesn't claim support past 4.16, but I was still wondering if someone could look into the issue.

Andrew Tram commented Mar 26 '22, 8:26 p.m.

  Interestingly enough, Eclipse 4.23 does include a lower version of javax.servlet compared to 4.21 - javax.servlet_3.0.0.v201112011016.jar vs javax.servlet_3.1.0.v201410161800.jar

Andrew Tram commented Mar 26 '22, 8:50 p.m.

 Eclipse 4.21, javax.servlet_3.1.0.v201410161800

Bundle-SymbolicName: javax.servlet
Bundle-Version: 3.1.0.v201410161800
Export-Package: javax.servlet;version="3.1.0";uses:="javax.servlet.des

Andrew Tram commented Mar 26 '22, 8:51 p.m.

 Eclipse 4.23, javax.servlet_3.0.0.v201112011016

Bundle-SymbolicName: javax.servlet
Export-Package: javax.servlet;version="2.6.0";uses:="javax.servlet.ann
Bundle-Version: 3.0.0.v201112011016

Ralph Schoon commented Mar 29 '22, 2:09 a.m.

Do you use the  P2 install?

Andrew Tram commented Mar 29 '22, 6:25 p.m.

That's correct. It was a P2 install on top of Eclipse Eclipse IDE for RCP and RAP Developers 4.22/ 4.23

3 answers

permanent link
Ralph Schoon (63.2k33646) | answered Mar 30 '22, 2:50 a.m.
edited Mar 30 '22, 3:44 a.m.

I have not used the latest and greatest Eclipse version with EWM lately. I have seen issues in the past. 

Go to All Platforms. Eclipse support is documented in the Prerequisites. The link I get does not work here. 

Supported versions are 4.4, 4.5, 4.6, and now the ones with future fixpacks 4.7, 4.8, 4.11, 4.14, 4.16

There is no support for the versions you list, as far as I can tell. 

Also note the Java SDK currently only Java 8 is supported at the moment.

permanent link
David Honey (1.8k17) | answered Mar 30 '22, 4:50 a.m.

I use Eclipse 2021-06 (4.20) with an EWM 7.0.2 p2 plugin for my everyday Jazz development. That version requires Java 11 to run. I tried Eclipse 2021-12, but there was a problem with the EWM 7.0.2 plugin with that Eclipse, for which a defect was submitted. However, as Ralph mentions, Eclipse versions later than 4.16 are currently not officially supported.

permanent link
Andrew Tram (11) | answered Mar 30 '22, 5:42 p.m.

Interestingly enough, starting with Eclipse 4.21, checking for updates and moving it up to 4.23, then install EWM 7.0.2 works.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.