It's all about the answers!

Ask a question

The server version is 25, and the client version is 27, due to which it shows me error uploading data


0
1
Paramdeep Singh Chhabra (131) | asked Feb 10 '22, 4:16 a.m.

 Hi Team, 


I recently installed EWM client (7.0.2), however when I tried to upload some data, it showed me the error that ''The following model has a version mismatch. The server version is 25 and the client version is 27. The client and the server version must match.'' 

I checked with my team and they have client 6.0.2, which works fine. Should I also get that installed to make it work? 

Please support!

Thank you.

Accepted answer


permanent link
Ralph Schoon (61.5k33643) | answered Feb 10 '22, 4:25 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The error message tells you that you are using a newer version of the EWM Eclipse client than the Version of the EWM Server. This is not supported and the server rejects the connection. 

EWM supports N-1 compatibility (unless stated otherwise). For any version of the EWM server you can run the same version of the Eclipse client or older versions up to a major version before. 


If your server is running for example 6.0.6.1 - which you can find out by  clicking on the question mark in the Web UI and selecting About This Application - you can run a 6.0.6.1 version of the client or an older up to 5.x.
It is recommended to use the same version of the client, if at all possible, but the backward compatibility tries to allow for a seamless upgrade experience.

Paramdeep Singh Chhabra selected this answer as the correct answer

Your answer


Register or to post your answer.