It's all about the answers!

Ask a question

Dynamic data source: How to check whether data exists?


Thomas Noack (60213) | asked Sep 26 '21, 1:55 p.m.
edited Sep 26 '21, 2:07 p.m.

 Many use cases, where we need to check, whether the data exists, e.g.

- Get all TCRs of a Test Plan (TCRs might be in trash -> they are in the Test Plan but when requesting them, RPE/PUB crashes with "none of the known protocols succeeded"

I have tried around a lot but did not find an answer yet.
Currently, I'm getting the feed and ask, if TCR is in feed. BUT: automated tests lead to 500k TCRs in project. From performance perspective, asking for existence via feed is not feasible.

Anyone knows, how to test within RPE, whether any ETM source exists?
Something like _sessionInfo.getDatasourceProperty("data", "status code", "") -> 200, 404, 500 ... would be cool.

-> How to reproduce:

3 answers



permanent link
Bartosz Chrabski (3.4k12849) | answered Sep 26 '21, 2:19 p.m.
edited Sep 26 '21, 2:25 p.m.
Thomas,

First of all if You want to filter You should use feed data schema and not full.

Do not get all the TCERs in the project because it is kill for the report and ETM itself.

With feed schema You can use filtering the same as you have in REST APIs.

<feedUrl>?fields=feed/entry/content/testplan[(href='https://...')]/*

Be aware the ETM has different Reportable API from DNG which has some additional advantages.

You will get empty feed is data does not exist. More in this article:
.

Comments
Thomas Noack commented Sep 26 '21, 2:48 p.m. | edited Sep 26 '21, 2:48 p.m.

Hi Bartosz. I found another solution, see comment below.


I need that for every single artifact type in ETM, i.e.
- Test Plans
- Tets Suites
- TCRs
- ... anything that can be requested.

For many of the types, needed feed filters do not exists (e.g., I often do not have a Test Plan, only a list of 3.000 TCRs collected from DOORS Classic)


permanent link
Thomas Noack (60213) | answered Sep 26 '21, 2:45 p.m.

 Ah I found it out by myself - finally :)


Set metadata property "Ignore Data Source Configuration Error" to true.
-> Before data source "exists=false"
-> In container when retrieving the data "exists=true"
-> Afterwards: do exception handling


permanent link
Bartosz Chrabski (3.4k12849) | answered Sep 26 '21, 3:06 p.m.
edited Sep 26 '21, 3:07 p.m.

Be aware that ignore enabled will ignore all the errors and you can have report with incomplete data.


It is enabling ignore for all the data sources in your report.

I do not think it is solving your performance issue.

Happy that You found solution good for You.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.