It's all about the answers!

Ask a question

How to get jts to recognize java 8 when installing rtc 6.0.3 with iFix017 and eclipse 4.8 (Photon) as a client.


Keith Eberhard (194) | asked Feb 24 '20, 12:32 p.m.

I am getting the error "Jazz encountered an error when attempting to determine the version of your Java virtual machine. You might be running on an unsupported Java virtual machine."


I have copied the jre files from ibm-java-jre-80-win-x86_64.

Server Administration shows the following for Server VM:

VM Error   CRJAZ2198E Jazz encountered an error when attempting to determine the version of your Java virtual machine. You might be running on an unsupported Java virtual machine.
Version   1.8.0_221
Vendor    IBM Corporation
Name     IBM J9 VM
Details   JRE 1.8.0 Windows 10 amd64-64-Bit Compressed Reference 20190802_424001 (JIT enabled, AOT   enabled)
             OpenJ9 - 106f6ce
             OMR -fe7f6f
             IBM - af2a365

About the Server shows that JTS Patch is active for 6.0.3 iFix017.

One answer



permanent link
Param S (275) | answered Mar 22 '20, 7:24 p.m.

 I think Java 8 is supported 6.0.6.1 onwards, not before it. Please use Java 7 if you want to use 6.0.3.

Your answer


Register or to post your answer.