It's all about the answers!

Ask a question

Getting Requirement Creation Factory from service provider XML file

A Ragab (117) | asked May 13 '19, 6:34 p.m.


We have two different test DNG servers, and in one of them I'm able to see the Requirement Creation Factory in the services.xml service provider XML file, while I don't see it in the other. Both projects/components are configuration aware.
i'm referring to the URL <server>/rm/oslc_rm/_k6OTgD2hEeic14vgzZaL8g/services.xml which i got from the rm/oslc_rm/catalog page.

The two servers are supposedly have identical configurations, and I have permissions to access and create requirements in the projects on both servers.

Any hints/clues why the "Requirement Creation Factory" doesn't appear in the catalog of second server? Is there any settings that control whether the Creation Factory appear or not?

4 answers

permanent link
Ralph Schoon (62.7k33643) | answered May 14 '19, 2:07 a.m.

 _k6OTgD2hEeic14vgzZaL8g is the UID of a project area. They are UIDs because they are UNIQUE. _k6OTgD2hEeic14vgzZaL8g is most likely not a project area on the other server (except it is a backup).

A Ragab commented May 14 '19, 4:07 a.m.

I use different UUIDs of course. The starting point is the catalog so I’m getting the correct services.xml links and I see the other providers including ReqIF there. Just not the creation providers 

permanent link
Rustam Zaidullin (53) | answered May 14 '19, 2:45 a.m.

I didn't catch the idea of expected result. But if you are trying to link two RM projects, placed on different servers, you need to add them to a GC project.

A Ragab commented May 14 '19, 4:09 a.m.

The usecase is not about linking two projects. It is just getting OSLC requirement creation factory service from the service provider catalog 

permanent link
Jim Amsden (26837) | answered May 14 '19, 7:43 a.m.

 The service provider should have a creation factory for at least Requirement and RequirementCollection. Are you able to login to that DNG server, open the project area and create requirements? If so, then the service.xml file would have to have the creation factories and there must be something else wrong.

A Ragab commented May 14 '19, 7:49 a.m.

I can create requirements and modules. I even have administrator rights on the second project where I’m not getting the creation factories.

> there must be something else wrong

Any idea or hints where to look is appreciated. Server configuration? Project settings? Logs?


permanent link
Jim Amsden (26837) | answered May 14 '19, 10:17 a.m.

 Can you establish consumer/friend relationship with that DNG server from RTC, and can you add an artifact container association to the project area and then create links between DNG and RTC?

If you can, then the creation factory should be there as that's what's used to create the link. Look at how you are getting the service.xml and make sure its the right one.

If not, then there's probably some corruption in the server.

Otherwise I don't have any other ideas.

A Ragab commented May 14 '19, 6:27 p.m.

Jim, thanks for the suggestion. We tried that today with no difference.

We actually created a new project and component on the second server and we can see the requirement creation factory in the services offered, however it still doesn't show up in the first project, so this narrow it down to the project (or component) settings.

Your answer

Register or to post your answer.