It's all about the answers!

Ask a question

Rational Design Manager 6.0.3 upgrade to 6.0.6 fails with invalid bundles error


Tojan John (117737) | asked May 13, 4:11 a.m.

 I am upgrading Rational Design Manager 6.0.3 to 6.0.6 version on windows environment. While running the dm_upgrade script below error occurs and upgrade fails.



---------------------------------------------------------

CRJAZ1218E The "com.ibm.rational.carter.ide.client" bundle with the id 655 is in
valid, the bundle is not RESOLVED.  Examine the the diagnostics that follow this
 message to determine why the bundle cannot be resolved.
com.ibm.rational.carter.ide.client [655]
  Unresolved requirement: Require-Bundle: com.ibm.xtools.rmps.web.app
    -> Bundle-SymbolicName: com.ibm.xtools.rmps.web.app; bundle-version="6.0.100
.v20180517_2237"; singleton:="true"
       com.ibm.xtools.rmps.web.app [268]
         Unresolved requirement: Require-Bundle: com.ibm.xtools.rmps.groups; bun
dle-version="[6.0.0,7.0.0)"
           -> Bundle-SymbolicName: com.ibm.xtools.rmps.groups; bundle-version="6
.0.200.v20180517_2237"; singleton:="true"
              com.ibm.xtools.rmps.groups [272]
                Unresolved requirement: Require-Bundle: com.ibm.xtools.rmps.fron
tservice; bundle-version="[6.0.100,7.0.0)"
                  -> Bundle-SymbolicName: com.ibm.xtools.rmps.frontservice; bund
le-version="6.0.300.v20180517_2237"; singleton:="true"
                     com.ibm.xtools.rmps.frontservice [262]
                       Unresolved requirement: Require-Bundle: jackson.core.asl


To ignore invalid bundles, re-run repotools with the following property definiti
on enabled in the script:
        -Dcom.ibm.team.repotools.rcp.allowInvalidBundles=true

The dm upgrade failed at step 0.  Correct the problem and run the script again s
tarting at step 0.

One answer



permanent link
Tojan John (117737) | answered May 13, 5:11 a.m.

 Issue got resolved by provisioning the repo again with -clean command

Your answer


Register or to post your answer.