It's all about the answers!

Ask a question

RPE Template as RQM Report Resource in Web UI: How to be Configuration Aware?

Bob 3 (1481158) | asked Apr 08 '19, 11:18 a.m.
edited Apr 08 '19, 11:29 a.m.

I would like to upload an RPE template to the RQM web UI as a report resource. My RQM project area is configuration managed and has several components and streams. When I create the report from the uploaded RPE resource, I get no results and no errors. I suspect that this is because the report is not configuration aware.

I am using the default RQM RPE template that comes with RPE installations out-of-the-box: QM_TestPlanWithTestcases.dta
The only change I made was to the template's data source configuration metadata, which I completed according to this work instruction:

Here is how the report is configured in the RQM web UI:
https://<server URL>/qm/service/ System (QM)/testplan?fields=feed/entry/content/testplan
Can anyone guide me on how to configure the report to be configuration-aware from the RQM web UI report interface?

One thought I had was to append a configuration-specifier to the end of the RQM TestPlan Feed URL that is provided in the report setup (see screen capture above), the same way DNG adds configuration context to the URL. I am not sure if RQM supports this.


One answer

permanent link
Subramanya Prasad Pilar (4.6k14) | answered Apr 19 '19, 1:18 p.m.
If you are using QM_TestPlanWithTestcases.dta that comes with RPE, you should use testplan feed url and not individual testplan url. It looks like with configuration metadata, you are selecting a testplan and hence individual testplan url is used for document generation, which is not correct.

Also, if configuration is enabled, you should make sure that oslc_config.context parameter is appended to the data source URL.
You can select configuration context using configuration picker. In my example, it is:
This is what you can do in RPE template:
Use a Data Source Configuration element and modify the URI property by appending oslc_config.context parameter.

Your answer

Register or to post your answer.