It's all about the answers!

Ask a question

Cannot run dynamic queries : receiving Runtime Error


nannette Mori (50677) | asked Feb 22 '19, 6:17 p.m.

RTC version 6.0.3

Websphere Application servier 8.5.5.12

My dynamic query is not able to "refresh" and this problem is user specific.  My - coworkers in my group can run the dynamic queries with no problem.  There are a few other users that cannot run dynamic queries.  I have tried to run the dynamic queries on other machines and I still get runtime error. 

Below are the steps I performed

Access my JRS report query and run the query

Select Export Option in JRS

Select Option to download query to Microsoft Excel with live data

In Excel I select "Enable Editing"

Click on "Make Results Dynamic" button

Before I click on "Make Results Dynamic" I click on the query results tab and ensure there is query data results displaying

After I click on "Make Results Dynamic" Button

Credential window displays

I enter my user name and Password

after I enter my user name and Password I immediately get the error "Runtime Error 1004 Application-defined or object defined Error

I click on debug which takes me to the line "refresh Background" = false

If I copy the Query URL and past into my excel worksheet in Data->Fron Web

select Go

asks for my credentials

Click on arrow to select the tables I want to import and click on import

credential window displays (says it is trying to access the JTS server)

I enter my username and Password

Receive Error Unable to open https/jts server location/rs/query/5596/dataservice?limit=1&basicAuthenticationEnabled=true&report=5586 - Cannot download the information you requested.

I receive both of the errors above on any query I try to run dynamically using JRS query.  However it seems to be user specific.  Some users get this error and others do not.  Our Sysadmin group cannot identify differences between the users profile that can run the dynamic queries and the users that cannot.  Does anyone know what can be causing this user specific problem or tell me how I can troubleshoot to find what is causing this error??? 


Comments
Bharath Rao commented Feb 25 '19, 2:23 a.m. | edited Feb 25 '19, 2:29 a.m.

Hi,


You could use Fiddler / Wireshark to get more details on the error from the network trace.

Additionally, you could look at the difference in user roles / permission for the project areas / applications where the issue is seen.

Hope this help!

Be the first one to answer this question!


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.